summaryrefslogtreecommitdiff
path: root/dev-python/nose2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nose2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nose2')
-rw-r--r--dev-python/nose2/Manifest3
-rw-r--r--dev-python/nose2/metadata.xml7
-rw-r--r--dev-python/nose2/nose2-0.6.5.ebuild43
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/nose2/Manifest b/dev-python/nose2/Manifest
new file mode 100644
index 000000000000..1ecafce772d4
--- /dev/null
+++ b/dev-python/nose2/Manifest
@@ -0,0 +1,3 @@
+DIST nose2-0.6.5.tar.gz 134808 BLAKE2B 5f094d537ff7c48b7bfaf139b4c96a93875013ca5663d1e5b3feec543e7efd55335488321bcdd5752529cb36685dd28c91bd29665aed9e5f58fef837e5e2944b SHA512 fc84aa19d486ff1441dd43666182212e4a05b3be054f3c8967e36e624c08ee6eb10b01bba45b5f5dbbd38cfd057d53877e0bc0d9aba59b842688a5d4ec944b40
+EBUILD nose2-0.6.5.ebuild 949 BLAKE2B 8c0a07cdc9f8eb1629ae4e7268fc22021fcc696db1a6fc76d3d40feb9bc560d9dd40fa0278c1861b0d0586b1c230743fdb7118f55a18d853eaa69584c4977bb5 SHA512 fdec07f6dc06acdddf7a9524be89b925d2fa443426cb0adc7c26cd2bee043a557af0a24e5dee10198b1712faec5a19ec9e23991411c6061a1850abef6ea6caf4
+MISC metadata.xml 219 BLAKE2B d029050891ce875c82037bc06584e6ac7cf5332227737dcb08449ff842d361f1f373d90fe5628b6305d8b372fdec3e66adf1fb6d7b3856bc444e0a899f7d0c5b SHA512 f7f050059c8022343085629b71dc33b31c18acac3ba51fefb5ef64c8bb0933a11fae700f12033c3e757f86c17fc41eed75d5e7c4394ca4cd9bd5aa2641c93150
diff --git a/dev-python/nose2/metadata.xml b/dev-python/nose2/metadata.xml
new file mode 100644
index 000000000000..1e3940e0914e
--- /dev/null
+++ b/dev-python/nose2/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">nose-devs/nose2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nose2/nose2-0.6.5.ebuild b/dev-python/nose2/nose2-0.6.5.ebuild
new file mode 100644
index 000000000000..261f44e72550
--- /dev/null
+++ b/dev-python/nose2/nose2-0.6.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="nose2 is the next generation of nicer testing for Python"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${CDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cov-core-1.12[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}