summaryrefslogtreecommitdiff
path: root/dev-python/nose2/nose2-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/nose2/nose2-0.10.0.ebuild
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/nose2/nose2-0.10.0.ebuild')
-rw-r--r--dev-python/nose2/nose2-0.10.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/nose2/nose2-0.10.0.ebuild b/dev-python/nose2/nose2-0.10.0.ebuild
new file mode 100644
index 000000000000..1f4c68ec3af2
--- /dev/null
+++ b/dev-python/nose2/nose2-0.10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Next generation unittest with plugins"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+# Failures need investigating
+RESTRICT="test"
+
+BDEPEND="
+ doc? ( >=dev-python/sphinx-1.0.5 )
+"
+DEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.1[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}