summaryrefslogtreecommitdiff
path: root/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/nose-testconfig/nose-testconfig-0.10.ebuild')
-rw-r--r--dev-python/nose-testconfig/nose-testconfig-0.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild b/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
new file mode 100644
index 000000000000..14fa44305e2a
--- /dev/null
+++ b/dev-python/nose-testconfig/nose-testconfig-0.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Configuration plugin for nosetests"
+HOMEPAGE="https://bitbucket.org/jnoller/nose-testconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/nose"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( docs/index.txt )
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}