summaryrefslogtreecommitdiff
path: root/dev-python/nose-random/nose-random-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/nose-random/nose-random-1.0.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/nose-random/nose-random-1.0.0.ebuild')
-rw-r--r--dev-python/nose-random/nose-random-1.0.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/nose-random/nose-random-1.0.0.ebuild b/dev-python/nose-random/nose-random-1.0.0.ebuild
new file mode 100644
index 000000000000..c4a593c95802
--- /dev/null
+++ b/dev-python/nose-random/nose-random-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to facilitate randomized unit testing"
+HOMEPAGE="https://github.com/fzumstein/nose-random"
+SRC_URI="https://github.com/fzumstein/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+# no tests