summaryrefslogtreecommitdiff
path: root/dev-python/nnpy/nnpy-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nnpy/nnpy-1.4.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nnpy/nnpy-1.4.2.ebuild')
-rw-r--r--dev-python/nnpy/nnpy-1.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/nnpy/nnpy-1.4.2.ebuild b/dev-python/nnpy/nnpy-1.4.2.ebuild
new file mode 100644
index 000000000000..03f745b7b9fc
--- /dev/null
+++ b/dev-python/nnpy/nnpy-1.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="cffi-based Python bindings for nanomsg"
+HOMEPAGE="https://github.com/nanomsg/nnpy"
+SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-libs/nanomsg:=
+"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
+}