summaryrefslogtreecommitdiff
path: root/dev-python/nnpy/nnpy-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/nnpy/nnpy-1.4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/nnpy/nnpy-1.4.1.ebuild')
-rw-r--r--dev-python/nnpy/nnpy-1.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/nnpy/nnpy-1.4.1.ebuild b/dev-python/nnpy/nnpy-1.4.1.ebuild
new file mode 100644
index 000000000000..7f1153859ae0
--- /dev/null
+++ b/dev-python/nnpy/nnpy-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="cffi-based Python bindings for nanomsg"
+HOMEPAGE="https://github.com/nanomsg/nnpy"
+SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-libs/nanomsg:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/py3.patch" )
+
+python_test() {
+ PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
+}