summaryrefslogtreecommitdiff
path: root/dev-python/nextinspace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-06 05:33:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-06 05:33:06 +0100
commit0922e7f160098c343e6e41a5e167a69b9e035db6 (patch)
treeabd00e1d8cb2ed02d2d5de1d3e6e345a9d362174 /dev-python/nextinspace
parent930b5a700c6f4093c4b63eec7395c080ab639311 (diff)
gentoo auto-resync : 06:05:2023 - 05:33:06
Diffstat (limited to 'dev-python/nextinspace')
-rw-r--r--dev-python/nextinspace/Manifest4
-rw-r--r--dev-python/nextinspace/metadata.xml22
-rw-r--r--dev-python/nextinspace/nextinspace-2.0.5.ebuild43
-rw-r--r--dev-python/nextinspace/nextinspace-9999.ebuild43
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/nextinspace/Manifest b/dev-python/nextinspace/Manifest
new file mode 100644
index 000000000000..ccdd7404136e
--- /dev/null
+++ b/dev-python/nextinspace/Manifest
@@ -0,0 +1,4 @@
+DIST nextinspace-2.0.5.gh.tar.gz 48406 BLAKE2B 6f6e2c95fc1a5a8175faca4df0a51de9996ca24847926dc35b94d0e4bd5c9de880ad757606309f622f41c825d0c2e46c587f255573b4df70fe35c937148af9d7 SHA512 c8f55446d9eea0409afb8a8ddb41001b18b55d9105d007b306717a3d932ea1b03ecb2363d0deb42ec8da1cc245b77ffb18cee6ec3474121c15c4c9b79ff80405
+EBUILD nextinspace-2.0.5.ebuild 1003 BLAKE2B e603487da97bacfe986ec63cb32d1afc6aad8d2445e4f9d97294629cbb2945aac59f6ca7456229121c66f626e8af9113246c5429627dc96e6483ae9970dbfc07 SHA512 cada41645b8d9d1e754a6dc0a81649aa06fcd46a7626e7776b77b70014d50523789648da11ac5944295a458fcba760b9e91cfb8ecfdb18c8c398f58bb96f0797
+EBUILD nextinspace-9999.ebuild 1003 BLAKE2B e603487da97bacfe986ec63cb32d1afc6aad8d2445e4f9d97294629cbb2945aac59f6ca7456229121c66f626e8af9113246c5429627dc96e6483ae9970dbfc07 SHA512 cada41645b8d9d1e754a6dc0a81649aa06fcd46a7626e7776b77b70014d50523789648da11ac5944295a458fcba760b9e91cfb8ecfdb18c8c398f58bb96f0797
+MISC metadata.xml 842 BLAKE2B 474983307f5e6669ce25e6dc44c65597a59e0089a4c66ad0c531b2ab634c0505e0208c8b55ffe333af4641c227b1b3b5f71515cba441e91f2be3c53c5d53f2d7 SHA512 28aa458b6d9be33d07c615d842726789bb39ea0ed966b261417c33197e279474034e91afadeb2c91d9c9b80b4d54bd68d6ce5a89afc16891d3d8d007ee0e3d5e
diff --git a/dev-python/nextinspace/metadata.xml b/dev-python/nextinspace/metadata.xml
new file mode 100644
index 000000000000..56879b2e53b6
--- /dev/null
+++ b/dev-python/nextinspace/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A command-line tool for seeing the latest in space. Nextinspace also
+ supports use as a Python library, so you can integrate it into your
+ application. You can also get data printed to the terminal in JSON,
+ which can be piped into another program.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gideonshaked/nextinspace</remote-id>
+ <remote-id type="pypi">nextinspace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nextinspace/nextinspace-2.0.5.ebuild b/dev-python/nextinspace/nextinspace-2.0.5.ebuild
new file mode 100644
index 000000000000..81347649c9dc
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-2.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-lazy-fixture-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Don't install license files
+ sed -e '/^include = \["LICENSE"\]$/d' -i pyproject.toml || die
+}
diff --git a/dev-python/nextinspace/nextinspace-9999.ebuild b/dev-python/nextinspace/nextinspace-9999.ebuild
new file mode 100644
index 000000000000..81347649c9dc
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-lazy-fixture-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Don't install license files
+ sed -e '/^include = \["LICENSE"\]$/d' -i pyproject.toml || die
+}