summaryrefslogtreecommitdiff
path: root/dev-python/nextinspace/nextinspace-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-22 06:30:44 +0000
commit5a2cecfc8661e1d3a762adf05cf8eb142cd41710 (patch)
tree341806a72603cc8845e7e1595289e7a8b9570f2a /dev-python/nextinspace/nextinspace-3.0.1.ebuild
parentd2bcdab82e5f5f38a8ab54026e8aa94edb1b77a6 (diff)
gentoo auto-resync : 22:12:2024 - 06:30:44HEADmaster
Diffstat (limited to 'dev-python/nextinspace/nextinspace-3.0.1.ebuild')
-rw-r--r--dev-python/nextinspace/nextinspace-3.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/nextinspace/nextinspace-3.0.1.ebuild b/dev-python/nextinspace/nextinspace-3.0.1.ebuild
new file mode 100644
index 000000000000..5d72a32bb012
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-3.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest