summaryrefslogtreecommitdiff
path: root/dev-python/nevow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nevow
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nevow')
-rw-r--r--dev-python/nevow/Manifest5
-rw-r--r--dev-python/nevow/metadata.xml11
-rw-r--r--dev-python/nevow/nevow-0.11.1.ebuild40
-rw-r--r--dev-python/nevow/nevow-0.14.3.ebuild52
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/nevow/Manifest b/dev-python/nevow/Manifest
new file mode 100644
index 000000000000..a22758b67b2e
--- /dev/null
+++ b/dev-python/nevow/Manifest
@@ -0,0 +1,5 @@
+DIST Nevow-0.11.1.tar.gz 563061 BLAKE2B 7763816e44a9b388edd0a77ad3e814514ff2ed2d28c156885bc6517860e17347a946c7b890c4d0688c4c08f60d76832403a772b4754d527c575aa4d8b4f7f3ed SHA512 a7e52fbf6915498e77a41fb100d4c688fcd0567deb56ec946adf1b1712bcfbec7b7a55c551e414606218146772d5274973af7851a78878635e900a4df5193a53
+DIST Nevow-0.14.3.tar.gz 548818 BLAKE2B 64b5bd46511a4c6c10bdd4335d1e2789e7dfe22e4e4bb014c03fd4949eb701f7f79095e8a239a974d89f0831399766e1b0fad0011f102c70af375d9460a7b63a SHA512 5488be9c771dc9d9b348ee705f8cb1f47400b4789ea574f5ed68c54ecb33e6cc2928d45193137921727f560256e16716adff66ca5179d2a79eb395e0d61c2f05
+EBUILD nevow-0.11.1.ebuild 1017 BLAKE2B ca230d7ab5def154b4514ebefe66377a3e155d8a9a164508769aaa3fd94d440a57ad12ebfad04344c4660672d2d4e0ecff27a60fdd4c42d73b43f787b71566d6 SHA512 3605a23ab8ce892362679158ba6503179c385bb2a0ccd4b74df9f806517306dd55255065aeb6d70b52d20952051fcb376c017267f10ef62f36baac5285ca7ead
+EBUILD nevow-0.14.3.ebuild 1262 BLAKE2B b42bb4d48d553b9f97f1b16b459b298e12ed679c4219707df9770ef534c03cafd22c51d85ee874316f8f6e285e7fe70ca834941f50ecd8e8dfc6fac5b8467dd9 SHA512 c62b067ab9d0bef10762d1f2d6e25592dc856fbb42ca320aab45824efcf845a95207406752883bc9ba5ea4e325a8afc6f462851b24e6c814066a73d0534016ff
+MISC metadata.xml 308 BLAKE2B b7948b5e8794cdbcc882fcec0ec0c4d754e44232dd1cb65932a8d92193b16751bcde6c0cc4ea6f79f93083d948b9b64dfa8ea116d085cc87f121cfb9a2c1160f SHA512 f6315f9350d7d43c1c2df8665f38e6373a1b24ff9950001472333ed45aceb10fd7dcf376492643e6af0a995f561f3fa171341303a4935bd55d97ce2fd6db9229
diff --git a/dev-python/nevow/metadata.xml b/dev-python/nevow/metadata.xml
new file mode 100644
index 000000000000..916525ee0a88
--- /dev/null
+++ b/dev-python/nevow/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Nevow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nevow/nevow-0.11.1.ebuild b/dev-python/nevow/nevow-0.11.1.ebuild
new file mode 100644
index 000000000000..5522b434193c
--- /dev/null
+++ b/dev-python/nevow/nevow-0.11.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit"
+HOMEPAGE="https://github.com/twisted/nevow https://pypi.org/project/Nevow/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( nevow.plugins )
+
+python_test() {
+ trial formless nevow || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/nevow/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # TODO: prevent installing it
+ rm -r "${D}"/usr/doc || die
+}
diff --git a/dev-python/nevow/nevow-0.14.3.ebuild b/dev-python/nevow/nevow-0.14.3.ebuild
new file mode 100644
index 000000000000..91f8d3cffa5f
--- /dev/null
+++ b/dev-python/nevow/nevow-0.14.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit"
+HOMEPAGE="https://github.com/twisted/nevow https://pypi.org/project/Nevow/"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ || (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ (
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ )
+ )
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+# JS tests require a JavaScript interpreter ('smjs' or 'js' in PATH)
+# and the subunit library
+DEPEND="${RDEPEND}
+ test? (
+ dev-lang/spidermonkey
+ dev-python/subunit[${PYTHON_USEDEP}]
+ )"
+
+TWISTED_PLUGINS=( nevow.plugins )
+
+python_test() {
+ trial formless nevow || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ touch "${D}$(python_get_sitedir)"/nevow/plugins/dropin.cache || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # TODO: prevent installing it
+ rm -r "${D}"/usr/doc || die
+}