summaryrefslogtreecommitdiff
path: root/dev-python/networkx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 02:44:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 02:44:06 +0100
commitf019a919bf109460ee009a5f9210b99d0467db97 (patch)
tree5e62ee11b837b7b408bb93bf2f01eb74f7b8a73f /dev-python/networkx
parent6a9905e269a1104c93dceb41e2627a8568642946 (diff)
gentoo auto-resync : 23:08:2022 - 02:44:06
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest2
-rw-r--r--dev-python/networkx/networkx-2.8.6.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 65fb7976fd38..b558f6f737f7 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,3 +1,5 @@
DIST networkx-2.8.5.tar.gz 1955125 BLAKE2B a98eb678f2d3b336e5675ac34b59677ead3d706347feb0150f553b49cad0f1936a5abf179eaa496e32b8e9d59103022e5103d9e2d758aac2df781f031254c2fb SHA512 0a4d50da0eff0ee7d79941d27bf07b5425493b92f482b4f91bd91a930e4e9c5eb1d3832aee44919aa708fd1e2d0a53fe2d77ff33864a54d0e3167b4108545dec
+DIST networkx-2.8.6.tar.gz 1957238 BLAKE2B 70c5256440d94c1b0fa01f733ef46fc5da6846cf57891b344b6a82c27029b983827ecec9f1154d47771cff464b789bf84a9150111a0ecf1533ec83f1d41b718b SHA512 d56ab1a3007a914227f09969c9300b0582a640e5c3ad35b25400d8159ec35986a5e9bad5d7f86f1474b7293f495471fa3cd9f3b890a0d5287646338128d09d35
EBUILD networkx-2.8.5.ebuild 1785 BLAKE2B d9eda063968fb759e1dc1aea0414fca466e124d2665ada088782718b501d70e1f41b9765c6859c139aeca476a06c621c2be51c1ae98d984f6c6a1f532b16128e SHA512 b801f14330c0405a005b7fbfc9fb745321636b37a978993d6e8871624a3ac69a846607b9d3f3e5d36c1ed0db5439eb70c8f661aee68fc5dcf07738fb5623d181
+EBUILD networkx-2.8.6.ebuild 1920 BLAKE2B 706b9648cc98041bd1bfde6d784c431da9fd555c467ba5a52e2849e6e65f9c20287b63c8a617e6bba19a29266a6010715a8e824db85798a6da6feeeee4048978 SHA512 c8a493e5f8fbf392732f4d525bc0743033ab2b956cda8a3d235964603e9a721a080b6ad5e0b3c651ffe0f3ce07be5606bb147d9d3379a063f8db226de6d2eb2a
MISC metadata.xml 1088 BLAKE2B 407d24ca890c5b2a7c49e5eab7f79477f66cb140ed286a7d0c65be075714c671c0185b067f7ced6e9a1cdc17361cfbeb406c306dafb915590abf6b5b1263a4a4 SHA512 2a790d427d6c4391d409f767359a256ee5b8082246811c82949b898e0a2a9f23e7c40bb045ff5eaf17f3cee04d7d24adcdf1ff0ae416ebd7b2572cfdcf04064f
diff --git a/dev-python/networkx/networkx-2.8.6.ebuild b/dev-python/networkx/networkx-2.8.6.ebuild
new file mode 100644
index 000000000000..36d89dddf71c
--- /dev/null
+++ b/dev-python/networkx/networkx-2.8.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{8..10} )
+# networkx skips tests w/ missing deps and the available ones all pass w/ py3.11
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" python3_11 )
+inherit distutils-r1 optfeature multiprocessing virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # virtx implies nonfatal
+ has_version "dev-python/scipy[${PYTHON_USEDEP}]" || local EPYTEST_DESELECT=(
+ networkx/drawing/tests/test_pylab.py::test_draw
+ )
+ nonfatal epytest -p no:django -n "$(makeopts_jobs)" || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "dev-python/gdal"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}