summaryrefslogtreecommitdiff
path: root/dev-python/networkx/networkx-2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/networkx/networkx-2.4-r1.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/networkx/networkx-2.4-r1.ebuild')
-rw-r--r--dev-python/networkx/networkx-2.4-r1.ebuild55
1 files changed, 23 insertions, 32 deletions
diff --git a/dev-python/networkx/networkx-2.4-r1.ebuild b/dev-python/networkx/networkx-2.4-r1.ebuild
index 081e31c0fa43..988703d38773 100644
--- a/dev-python/networkx/networkx-2.4-r1.ebuild
+++ b/dev-python/networkx/networkx-2.4-r1.ebuild
@@ -3,12 +3,11 @@
EAPI=7
-# networkx-2.4 supports up to python3_8
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
DESCRIPTION="Python tools to manipulate graphs and complex networks"
-HOMEPAGE="http://networkx.github.io/ https://github.com/networkx/networkx"
+HOMEPAGE="https://networkx.github.io/ https://github.com/networkx/networkx"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -17,41 +16,40 @@ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-
IUSE="examples extras pandas scipy test xml yaml"
RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( extras pandas scipy xml yaml )"
-
-COMMON_DEPEND="
+RDEPEND="
+ >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
>=dev-python/matplotlib-2.2.2[${PYTHON_USEDEP}]
extras? (
>=dev-python/pydot-1.2.4[${PYTHON_USEDEP}]
- >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
- >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pygraphviz-1.5[${PYTHON_USEDEP}]
+ >=sci-libs/gdal-1.10.0[python,${PYTHON_USEDEP}]
+ ' python3_{6,7,8})
)
pandas? (
- $(python_gen_cond_dep '>=dev-python/pandas-0.23.3[${PYTHON_USEDEP}]' python3_{6,7})
+ >=dev-python/pandas-0.23.3[${PYTHON_USEDEP}]
)
scipy? ( >=sci-libs/scipy-1.1.0[${PYTHON_USEDEP}] )
xml? ( >=dev-python/lxml-4.2.3[${PYTHON_USEDEP}] )
yaml? ( >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}] )"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/decorator-4.3.0[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- examples? (
- dev-python/pyparsing[${PYTHON_USEDEP}]
- )"
+
+distutils_enable_tests pytest
PATCHES=(
+ "${FILESDIR}"/${P}-py38.patch
+ "${FILESDIR}"/${P}-py39.patch
)
-python_test() {
- virtx nosetests -vv || die "tests failed with ${EPYTHON}"
+src_prepare() {
+ # incompatible deps?
+ sed -e 's:test_multigraph_edgelist_tuples:_&:' \
+ -i networkx/drawing/tests/test_pylab.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
}
python_install_all() {
@@ -59,10 +57,3 @@ python_install_all() {
distutils-r1_python_install_all
}
-
-pkg_postinst() {
- if use pandas && use python_targets_python3_8; then
- ewarn "The pandas functionality in ${P} will not work with python3.8 as"
- ewarn "dev-python/pandas does not have support for python3.8 yet"
- fi
-}