summaryrefslogtreecommitdiff
path: root/dev-python/netcdf4-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /dev-python/netcdf4-python
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'dev-python/netcdf4-python')
-rw-r--r--dev-python/netcdf4-python/Manifest3
-rw-r--r--dev-python/netcdf4-python/metadata.xml22
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.5.8.ebuild47
3 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/netcdf4-python/Manifest b/dev-python/netcdf4-python/Manifest
deleted file mode 100644
index 1f800ddcc3bf..000000000000
--- a/dev-python/netcdf4-python/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST netCDF4-1.5.8.tar.gz 767013 BLAKE2B 26e30b9ef74b6d1af07fadc5a0c93c1370c9e684b69345e18801c00691362766bce393b7fc8c0ccd4cd4b8e7ac448f3c69a1769e056c780c668c441cf0418b94 SHA512 b43e10356a60ecdd1aaa7585648242e9d610e042da8fd97f374617d7813cc9f35b4133a88ac4c10e921df12d5b2f2b1668af4fb69578b57b7c3d57a731579260
-EBUILD netcdf4-python-1.5.8.ebuild 1133 BLAKE2B 8bf3d43707973a29479df1d245e313adb89efdad8028926ccfb3e5e07ca3afd154067bf3089a6993325261574dbedba1932b234341c369e26ed70a4fbd5e6105 SHA512 e2596ef0515cc72f3061ed12125c19d49f9abc6e7eb2a0f74ff11b20575b04fa312ed0fa15a24fe95301f0df12d847bcc7f26095fa389f4a043c3c20851e305b
-MISC metadata.xml 782 BLAKE2B 13395c54962217119a1acd466d86c0afc4436955638d158fe6c495ce501cb2a6229d3ba5196a8836f2969cbe2b93927b9c89485e230cf667e3da426b61a28f2e SHA512 28b2fdd4c8d8d52d249f8b8cea8738d76ad1dcbfb170ac4f854be2d5228dfc86c93f8edd3b413c399067bf9203632e358d87461677630ee6acf98cc8aee6cc10
diff --git a/dev-python/netcdf4-python/metadata.xml b/dev-python/netcdf4-python/metadata.xml
deleted file mode 100644
index e9799992da68..000000000000
--- a/dev-python/netcdf4-python/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- netcdf4-python is a Python interface to the netCDF C library.
- netCDF version 4 can read and write files in both the new netCDF 4
- and the old netCDF 3 format, and can create files that are readable
- by HDF5 clients. The API modelled after Scientific.IO.NetCDF, and
- should be familiar to users of that module.
- </longdescription>
- <upstream>
- <remote-id type="pypi">netCDF4</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.5.8.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.5.8.ebuild
deleted file mode 100644
index 25f2870753da..000000000000
--- a/dev-python/netcdf4-python/netcdf4-python-1.5.8.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 optfeature
-
-MY_PN="netCDF4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python/numpy interface to the netCDF C library"
-HOMEPAGE="https://unidata.github.io/netcdf4-python/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- sci-libs/hdf5
- sci-libs/netcdf:=[hdf5]"
-RDEPEND="${DEPEND}
- dev-python/cftime[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- sci-libs/hdf5
- sci-libs/netcdf[hdf5,tools]
- dev-python/cftime[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- local -x NO_NET=1
- cd test || die
- "${EPYTHON}" run_all.py || die
-}
-
-pkg_postinst() {
- optfeature "HDF4 support" sci-libs/hdf "sci-libs/netcdf[hdf]"
- optfeature "MPI parallel IO support" "sci-libs/hdf5[mpi]" "sci-libs/netcdf[mpi]"
- optfeature "OPeNDAP support" net-misc/curl "sci-libs/netcdf[dap]"
-}