summaryrefslogtreecommitdiff
path: root/dev-python/netaddr/netaddr-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/netaddr/netaddr-0.8.0.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/netaddr/netaddr-0.8.0.ebuild')
-rw-r--r--dev-python/netaddr/netaddr-0.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/netaddr/netaddr-0.8.0.ebuild b/dev-python/netaddr/netaddr-0.8.0.ebuild
new file mode 100644
index 000000000000..cdd931175b5e
--- /dev/null
+++ b/dev-python/netaddr/netaddr-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Network address representation and manipulation library"
+HOMEPAGE="https://github.com/drkjam/netaddr https://pypi.org/project/netaddr/ https://netaddr.readthedocs.org"
+# The next release should have docs in the PyPI tarball
+# https://github.com/netaddr/netaddr/commit/e6f545fccd83dbd14baff40070594cc96838c9bf
+SRC_URI="https://github.com/netaddr/netaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cli"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+ cli? (
+ >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Disable coverage (requires additional plugins)
+ sed -i 's/^addopts = .*//' pytest.ini || die
+ distutils-r1_src_prepare
+}