summaryrefslogtreecommitdiff
path: root/dev-python/netaddr/netaddr-0.7.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/netaddr/netaddr-0.7.13.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/netaddr/netaddr-0.7.13.ebuild')
-rw-r--r--dev-python/netaddr/netaddr-0.7.13.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/netaddr/netaddr-0.7.13.ebuild b/dev-python/netaddr/netaddr-0.7.13.ebuild
new file mode 100644
index 000000000000..743661b49cdc
--- /dev/null
+++ b/dev-python/netaddr/netaddr-0.7.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Network address representation and manipulation library"
+HOMEPAGE="https://github.com/drkjam/netaddr https://pypi.python.org/pypi/netaddr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cli"
+
+DEPEND=""
+RDEPEND="cli? ( >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" netaddr/tests/__init__.py || die "Tests fail with ${EPYTHON}"
+}