summaryrefslogtreecommitdiff
path: root/dev-python/neovim-remote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
commit8fcdcec5fbdd0e3a77391e4f354218014f59f358 (patch)
treeb6aaf9c103052f2ab4a948377142f4a4233caa60 /dev-python/neovim-remote
parent423d21dcfee183cc4b04d29c1621615e8c30f834 (diff)
gentoo resync : 05.01.2018
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest4
-rw-r--r--dev-python/neovim-remote/metadata.xml12
-rw-r--r--dev-python/neovim-remote/neovim-remote-1.8.6.ebuild26
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild26
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
new file mode 100644
index 000000000000..6f9f53fb7f8d
--- /dev/null
+++ b/dev-python/neovim-remote/Manifest
@@ -0,0 +1,4 @@
+DIST neovim-remote-1.8.6.tar.gz 434012 BLAKE2B 1fddb5e4376d3d17c2ff0c00e5f98700ab2d221af1ed1bc3f9c6dabe9cf1bdafe9f85041cb3a01f9a45f03df2d76bc0ae3c5a93603caa9ad461eb5ae50cb832f SHA512 b973b8c495a3a371b9a21ec4110beebbfe304f00d73aaf1da849df612e6ea9a08258379600ccb8d83154b8ef12e26088ba90a1668c5262b7dc9c62c844f42798
+EBUILD neovim-remote-1.8.6.ebuild 667 BLAKE2B 8d5583fd913fff3f0883abc5c5b77fd1061bb4bcc60dd305f4053759b3ca1bdaee7b93c773d6a3d62970e19e1fc3276457918816796c2c58e5b1d1d9aec1d560 SHA512 c8aa7bf991906b7a61cf0b5b307289232974d9053d01cd25c6298c8a77c8de286b9d7a141977893301147a16dd402a082effac472144d4ba320db584abf151d2
+EBUILD neovim-remote-9999.ebuild 667 BLAKE2B 8d5583fd913fff3f0883abc5c5b77fd1061bb4bcc60dd305f4053759b3ca1bdaee7b93c773d6a3d62970e19e1fc3276457918816796c2c58e5b1d1d9aec1d560 SHA512 c8aa7bf991906b7a61cf0b5b307289232974d9053d01cd25c6298c8a77c8de286b9d7a141977893301147a16dd402a082effac472144d4ba320db584abf151d2
+MISC metadata.xml 362 BLAKE2B ccffe6e6b67304e57324196888c88050b8214c087edd9e3d63190d4b8e330de28cf6e1933c881ba9036e2c84d6cf58cc034f4a64055118ac075e7d160d0e7ba6 SHA512 e74ae96798c9ff4d0808eea25abfe55e9a086f194f973b27c14abdb17ae144145d561440fcab4a4986462fb63e962d1c4a2c18e16911cd520845b4f98080135a
diff --git a/dev-python/neovim-remote/metadata.xml b/dev-python/neovim-remote/metadata.xml
new file mode 100644
index 000000000000..76ed9960fb57
--- /dev/null
+++ b/dev-python/neovim-remote/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"