summaryrefslogtreecommitdiff
path: root/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
index ad71ec5355d3..3f2b0667f41d 100644
--- a/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${P/-/_}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 s390 sparc x86"
RDEPEND="
dev-python/pyaes[${PYTHON_USEDEP}]
@@ -28,16 +28,15 @@ DEPEND="${RDEPEND}
test? (
!!<dev-python/ndg-httpsclient-0.4.2-r1
dev-libs/openssl:0
- sys-libs/libfaketime
)"
+PATCHES=(
+ "${FILESDIR}/${P}-expiration-test-fix.patch"
+)
+
distutils_enable_tests unittest
src_test() {
- # bundled certificates expired, so we need a time machine
- local -x FAKETIME="@2019-12-01 12:00:00"
- local -x LD_PRELOAD="libfaketime.so:${LD_PRELOAD}"
-
# we need to start a fake https server for tests to connect to
( cd ndg/httpsclient/test && sh ./scripts/openssl_https_server.sh ) &
local server_pid=${!}