summaryrefslogtreecommitdiff
path: root/dev-python/nbxmpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
commit9e166f0fa8bc64fb267aaba88d9a55f8393e15a0 (patch)
tree8e5bf47e5b23c73057fb21ad97f5babca40da0cd /dev-python/nbxmpp
parentfd3c1be769bb61186a7d433ce694b0059a8f84a5 (diff)
gentoo auto-resync : 13:02:2024 - 05:35:50
Diffstat (limited to 'dev-python/nbxmpp')
-rw-r--r--dev-python/nbxmpp/Manifest2
-rw-r--r--dev-python/nbxmpp/nbxmpp-4.5.4.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/nbxmpp/Manifest b/dev-python/nbxmpp/Manifest
index a58c0be96a47..4b38f6b59873 100644
--- a/dev-python/nbxmpp/Manifest
+++ b/dev-python/nbxmpp/Manifest
@@ -1,3 +1,5 @@
DIST python-nbxmpp-4.5.3.tar.bz2 138080 BLAKE2B cb3051acc13f13d519ce4427121810cd17df7783a3c76c2abbab458be827b46be45a7710b0045e2b2a5619ffc327bd98c0a0db00f482e12223322811ca26d0c9 SHA512 d6dec900b56fb2638976206497e966ad27f566f4d829cc4d19e7f004ec39f2d2bd8f62c3322101df3a26004d7fc5be5a9691ce575234d801f3934b6a41ba5a0d
+DIST python-nbxmpp-4.5.4.tar.bz2 138170 BLAKE2B 00a4919032dd29828dc735695afe9c0814a8fe2ec765a534257768896d9f27bc3a395275d546ad717bdd16c97161e8f0a8acaf43cdb7bd9404e40bc72f2c3da5 SHA512 fcaedae519d8cd2d52cc65721ab1e743569ba1cf7c29f2db41ed5671ba0f2c5b47f1f6d9521e1614e89e21512a4575c6788316cdb86936f0c4886d54c3831bb3
EBUILD nbxmpp-4.5.3.ebuild 860 BLAKE2B d4ff7399de1b1854d44453b60830b69c5b9e2698414fe02d04e838e2208c111ada093f5924d1d1fb09eb4a6ab45b6bff147d599b0fe841c201784e848b318735 SHA512 51618fc4d06a809dc3286348067262a6d3248865d37a57f5a3a7ebc8914049ab37acfe63a653f46f8dead3db50731b575b97c5dfc4f2e741628edd4c1dcbd416
+EBUILD nbxmpp-4.5.4.ebuild 863 BLAKE2B bc8b493a0ef1dad73d5f525ea9fdc2b390152b06555483ca4ef9badb06cee059e0fb5692fc45998d40435f689cae40166e898bb7127bbe86eb56347e9f20984b SHA512 300c3ca772db17ef3099d0293a92fc0ba8c48866ea3af767235e6d91db8b13d6a364495d92f842e2f229f518874f6e191cc569f89e80d086a36743d0bd4063de
MISC metadata.xml 426 BLAKE2B 2772501445c7b3f8db801d5d6c52c6004cc6c67527b30cfcd5f48b54c3e483f1ace9307632f0da179cc4462e3ffde741b66af38c76e248004ff7238a591a15bf SHA512 0f456e67e255e045d97f969ed16c7e304d07a6b9a60d938dded30e78235a2ef984f5883c08f655e14084a8d76f54cd578c3d1eb387f0cc4d8502a5188dac987d
diff --git a/dev-python/nbxmpp/nbxmpp-4.5.4.ebuild b/dev-python/nbxmpp/nbxmpp-4.5.4.ebuild
new file mode 100644
index 000000000000..67560e6f811d
--- /dev/null
+++ b/dev-python/nbxmpp/nbxmpp-4.5.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-nbxmpp-${PV}
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.42[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest