summaryrefslogtreecommitdiff
path: root/dev-python/nbval
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nbval
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nbval')
-rw-r--r--dev-python/nbval/Manifest3
-rw-r--r--dev-python/nbval/metadata.xml31
-rw-r--r--dev-python/nbval/nbval-0.7.ebuild36
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/nbval/Manifest b/dev-python/nbval/Manifest
new file mode 100644
index 000000000000..50e89f9a05d0
--- /dev/null
+++ b/dev-python/nbval/Manifest
@@ -0,0 +1,3 @@
+DIST nbval-0.7.tar.gz 51805 BLAKE2B 3d1089cd480832847ca8ab5c64b69781216d4fbf2b33f7cb6a26e321062c3def85ab9620d3190451369f70b0051ed371e2df01bd0140859c98db3600cee3e543 SHA512 f146910d7fbd6a1f18b3d9ae006a1b252cc2e038f8a316463530b564e007b4b4e0b2daefbed7ae9ec7e14280f6f004b437c9570fd4d1e959c53165dcdf3cac5e
+EBUILD nbval-0.7.ebuild 815 BLAKE2B 833f4d635e0abb96d4ece255a38beddecfbc98cfa0c811b0d5a8991af5201f5e6a0a91bd4cce9e3a48b30d57ef20b221d1fed2f544a0b01a549789043bac0a8f SHA512 eb4a8c39e73420999de1341b488b9757f56aa5402aa7ffd72ce23593be4dc73c61b91070983dcc315afedb9ee426369dff5c756c2f766b17fa0dc105fea88bab
+MISC metadata.xml 1206 BLAKE2B dcac4a50dae5beebee0b8af144a0666c87f43474464d06a7ffb5a3c5f02501f760d346f9c10768a7065e6f5a054f2aa8e664a6f5f259306a6db691d90446cd53 SHA512 2408122c980076cea7021853c320bb48b93bae5cf20b4101c07681ee0ddf8e741ca39789b884ed04f9ab0ccb2817e9610387e6efc1dac512dc05c9c9126e2e36
diff --git a/dev-python/nbval/metadata.xml b/dev-python/nbval/metadata.xml
new file mode 100644
index 000000000000..19121442841d
--- /dev/null
+++ b/dev-python/nbval/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription>
+ The plugin adds functionality to py.test to recognise and collect Jupyter notebooks.
+ The intended purpose of the tests is to determine whether execution of the stored
+ inputs match the stored outputs of the .ipynb file. Whilst also ensuring that the
+ notebooks are running without errors.
+
+ The tests were designed to ensure that Jupyter notebooks (especially those for reference
+ and documentation), are executing consistently.
+
+ Each cell is taken as a test, a cell that doesn't reproduce the expected output will fail.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nbval</remote-id>
+ <remote-id type="github">computationalmodelling/nbval</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nbval/nbval-0.7.ebuild b/dev-python/nbval/nbval-0.7.ebuild
new file mode 100644
index 000000000000..fbb65c03f937
--- /dev/null
+++ b/dev-python/nbval/nbval-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
+HOMEPAGE="https://github.com/computationalmodelling/nbval"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ emake test
+}