summaryrefslogtreecommitdiff
path: root/dev-python/nbsphinx/nbsphinx-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /dev-python/nbsphinx/nbsphinx-0.4.1.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'dev-python/nbsphinx/nbsphinx-0.4.1.ebuild')
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.4.1.ebuild b/dev-python/nbsphinx/nbsphinx-0.4.1.ebuild
new file mode 100644
index 000000000000..a8a61ca85072
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.2[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"