summaryrefslogtreecommitdiff
path: root/dev-python/nbformat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/nbformat
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest2
-rw-r--r--dev-python/nbformat/nbformat-5.1.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index eacd15a75cd7..5671a8925598 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,4 +1,6 @@
AUX nbformat-5.1.2-package-data.patch 1396 BLAKE2B 60991048ef5b01f1a243e10daf81384b9dc35ea0f56e0b2385d08bea57b65dbb8084c988a767f17cf97d583a6bc1917bd110b448810ca93213c6dc9d0362512f SHA512 d75d579edb77132ba5385de780ab104c80efe38aa18cef092edefccae23aa701c4b642d0cec05e245796e0dc6f4349a84ebf72671229b625f1adb907c779e305
DIST nbformat-5.1.2.gh.tar.gz 152275 BLAKE2B 2a0758f33952547e5ef91f0ac0a8b98b97b882a8797c38feff6710a3a0824637f41396b152403e155e1af9805b7a85c189ba2a609076c591562e5f4bb783da29 SHA512 4fd574373c2f325b6d078a062878d139d741d30f9101f3344e0c7fc19bdf714f8ef71994134e76c90e1301102aac55cc490df8344f3ceb407002437f35d03944
+DIST nbformat-5.1.3.gh.tar.gz 130922 BLAKE2B 866eb53dd3f04c09f4a08303c5e84b672cc826d2d9b369cd85038b6c4075e74dce88fbcae80fc9b5450faf1c4971d121abe35e0a2ce2a8e73e020d2bed3a5594 SHA512 b4bc3d51d6e940ce1e2b1f5ca1005cf3d466b2b7b589383a31c4d2908c4e539344f4c8fb9e92993469d4d66f363c35082f0c16b8a63aa61e19fb24fa5ac910fd
EBUILD nbformat-5.1.2-r1.ebuild 935 BLAKE2B 52b270c6b77d42524378ff4c4bd09dbe6773cb22c810dfc16cc861c001694ad2cb8cba22ae40a791ee03a57f47f85631fa5a7ba23ff17dfa3b946893ea529c6c SHA512 514732c96b060fd333fce408cb79884f2056dcc73b78a2dffcf6865251d83ee1ecc46a474992177300f96e4d5661f86f27cdf75e0c2a1d64ac45bcbdeb1bf82b
+EBUILD nbformat-5.1.3.ebuild 876 BLAKE2B b92db08196584d6d9e38fb606a0d6e26adf6be6fc975b5b9ceb45f909f0382f63f7af093d87c1a8d8ff0710f9e47450a7671c882d6b7fe56b21d8b9cb93665a1 SHA512 e8a4ebb05a7707e2d65526879ce5d317a539d236ba0446d265af601e40142c40d5d97da2ebcdd86d4cd5b4cd7a605e92acf31a042fd59ded578b93aa5019552d
MISC metadata.xml 779 BLAKE2B 8608b59cf72c078896b57bf46337f7a0c78a727a4afa5272ac7a5420a39590977668d249cb84c994b9a402a0d59a43f3cb15433ed5eca0792d054fcccd291e96 SHA512 98249e1bfea7f79b978a5ae1e734113ff075c48fcfe042774ae48ccc0398bd17aba8a6267b7a58b4002d85e5e8af28e4a50c511900f7f400b6f3dacbc3cd64eb
diff --git a/dev-python/nbformat/nbformat-5.1.3.ebuild b/dev-python/nbformat/nbformat-5.1.3.ebuild
new file mode 100644
index 000000000000..40d57268d3bc
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+# missing on pypi
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest