summaryrefslogtreecommitdiff
path: root/dev-python/nbdime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nbdime
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest5
-rw-r--r--dev-python/nbdime/metadata.xml24
-rw-r--r--dev-python/nbdime/nbdime-0.1.2.ebuild54
-rw-r--r--dev-python/nbdime/nbdime-0.2.0.ebuild66
4 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
new file mode 100644
index 000000000000..7e9162c25949
--- /dev/null
+++ b/dev-python/nbdime/Manifest
@@ -0,0 +1,5 @@
+DIST nbdime-0.1.2.tar.gz 3864624 BLAKE2B dbf51b7eb07d08870fe1c629aa294b784fd95c0d547de3a4ea4fcf7da5ad6c490df3b61f3cb353723b3139137a54b534460c2a25a6480f7316b6fd17d742d661 SHA512 9f704645ef1e64b0da260841769068db6f6aba37f30b3c6506a1876af1276acb452ed78f66b9e6d7029f06ed9fabf01a1484b4b86055f27a451d623a7eda90cf
+DIST nbdime-0.2.0.tar.gz 4139079 BLAKE2B 1e6994009c8ac291272a297fe583f79123906c9e05ca2afd345c6e230e3c476259c4919e2161a049e46fa28f4490122c53d0a2bc94661683652d226a78fb39be SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d
+EBUILD nbdime-0.1.2.ebuild 1358 BLAKE2B 3f50c4b004d73bba22595e186b9cc9488248c383eebec7601a781703d5534625e4366b71c666eb3238bcaf5bc092f353f2767d0f289fd523b68c29cd08a7ae18 SHA512 04b6221791545222a081baf8a6cbaf7b043b182f8a10a42994680526f2c7bc2574de781c506a663adc0a8e5d3fd85eb82d108021c3518fcfb52806e4208018ec
+EBUILD nbdime-0.2.0.ebuild 1608 BLAKE2B 5cbf1a8acb1c105b87aec9082ed9371c9c4268e093da5d21be76bb4ead0c8c65473e4f5e7c7c9d6864caa094000b5d12bd7c20e87b1e9ca28fdbc2c21d35252c SHA512 c638784a5eab3db30067d16a52798457dafaa4e28aba8184afa7ac23ca5963eeebfe984ab90944ac0230ad8fa5a5c1299bc364deab8023c9118131566aa37f0b
+MISC metadata.xml 722 BLAKE2B fa4bd130e775cecbed839354417e50c931edd2fb00e24620ab90b782429ec2902bb32b7a0c683dc47986ef271a2485e6d9fded7d9a18e1930f1efc071924784c SHA512 0f319098fdae96681969217b5deedafca1908b8bf47e9603ca3ecef75c4461c61e64ce0fe20e7356713d2256de8267f4abf4162be8c0098930865f464914f59d
diff --git a/dev-python/nbdime/metadata.xml b/dev-python/nbdime/metadata.xml
new file mode 100644
index 000000000000..b2a229dc3754
--- /dev/null
+++ b/dev-python/nbdime/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ nbdime provides tools for diffing and merging of Jupyter Notebooks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/nbdime</remote-id>
+ <remote-id type="pypi">nbdime</remote-id>
+ </upstream>
+ <use>
+ <flag name="webtools">
+ Install web-based diff and merge tools.
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/dev-python/nbdime/nbdime-0.1.2.ebuild b/dev-python/nbdime/nbdime-0.1.2.ebuild
new file mode 100644
index 000000000000..f469ec14ebc7
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}
diff --git a/dev-python/nbdime/nbdime-0.2.0.ebuild b/dev-python/nbdime/nbdime-0.2.0.ebuild
new file mode 100644
index 000000000000..d407d7d26d2f
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}