summaryrefslogtreecommitdiff
path: root/dev-python/nbdime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-11 00:05:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-11 00:05:57 +0000
commit2e027f251732a168e55984da9d843155dca675c6 (patch)
tree36007a76d602b39328ad771ab22f7a3945518773 /dev-python/nbdime
parent17dcfeba22240edb3c54d96e319edf6c4bc008c3 (diff)
gentoo auto-resync : 11:03:2023 - 00:05:57
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest3
-rw-r--r--dev-python/nbdime/nbdime-3.1.1-r2.ebuild101
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index c49a980e60ee..08fb2f715ce1 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1,3 +1,6 @@
+DIST nbdime-3.1.1-jupyter_server2.patch 9483 BLAKE2B 767f7c848a5d840c1ac26d42f4074888163fd0bf63b774e9f79c5b7738f7f43453e35c93bdbad9cb10bb52315d67e1de6207b3463bbb885a6d095ada2bfae7ef SHA512 306764a2dd8770ee5041f5ebe076c3de5da9444166de3b77c7a6c37ef1a13c57f1adecf11e99a6f812930b133ae4ec7229de61f8a789804de77abd518f2e08b4
+DIST nbdime-3.1.1-py3.11.patch 873 BLAKE2B cc7e7a2cb7a95eb4280d1ee64b4563691c099e0c9d0613283dcbdf6cdebabc78f5c8f181006fb7176df43950ec86be880620e0381dffcf5614f8c05b78f7c4dd SHA512 e26054c7ed2c8201e3e6b6d4e18c80f3b5a3a9a21d201f2ba1f68cc2dcd0e6c4bc2d82c57cd07400f0ee6ce8a52e9a5c8e77000cd7912d3ca6b2ea53b80909fe
DIST nbdime-3.1.1.tar.gz 7723671 BLAKE2B 2a8f0e7281e1830d6ab15bcc25c1be69e37b575e4ecde1f61f5d697be8cf556c7e3bfdf11375f47808aa812bebbbaf4bfacaa121c17fefb9cc8a80ba9ca08d1c SHA512 268c2c3f8c45dd4a55a632d55a817ee4a4283c5411b73915bb514a9b546ebcdebd7481e93a1e7ba66c30bcdc70932ba7af83de454d3d0ab9d2cfa24bc19c8d9f
EBUILD nbdime-3.1.1-r1.ebuild 2498 BLAKE2B 62f136576b109f522c9effe76a87aa6be4255cdcc8c796a115cbc3c7706a1cbb969411fa697d1bd782cab8af2b7e723bae359e3f168b84adb6e071f125fbc911 SHA512 5c7838a7edec40fed0c17bf1f098ef1326cf17665ca71230d50ba607333525b53cdb12997315bc12d611aceee537e457b262be5c5dce633dc95dee51e5c93145
+EBUILD nbdime-3.1.1-r2.ebuild 2886 BLAKE2B bee2087c01158aa9e084d654e7590eb0a15c226e7350e6d44e8c1d8fd3be0c915322fee3505d4de496b6fd7b4c1cf4b5015c97e6030c64ac6c5e292b43bdbda8 SHA512 0109f4d39d0e6a94711d868c68a74c4596364e0e8bc6e923c74ecb3ffda3d0178b9736592f9d9e0f2a44ae989b936f568fe174ebed9afec1aed874a22534e23f
MISC metadata.xml 514 BLAKE2B c3062055cb710079162f879e3a7ca9cc1009946eba2e3d09f5cdfeb9f3bccbc12a9c6fe86d84f80d88b07eb17d03b55f8d1c6770b97c7a760015e4466e6fa531 SHA512 069589261da9b38841c363712255d55e2203c55af94ce62c3640a90139b6d260d2f1ba6475b9c0264b8c4530207cdb17983ebb2f67565fef9fce891603c1d3a3
diff --git a/dev-python/nbdime/nbdime-3.1.1-r2.ebuild b/dev-python/nbdime/nbdime-3.1.1-r2.ebuild
new file mode 100644
index 000000000000..4587c840c4d4
--- /dev/null
+++ b/dev-python/nbdime/nbdime-3.1.1-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi edos2unix
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbdime/
+ https://pypi.org/project/nbdime/
+"
+SRC_URI+="
+ https://github.com/jupyter/nbdime/commit/0e1cdaa77f57aa7f609d5ef7da26a52814c7ff74.patch
+ -> ${P}-jupyter_server2.patch
+ https://github.com/jupyter/nbdime/commit/f67a809262b45ed0eaedc840b0e5d979eaa6965d.patch
+ -> ${P}-py3.11.patch
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ dev-python/jupyter_server_mathjax[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/recommonmark \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${DISTDIR}"/${P}-jupyter_server2.patch
+ "${DISTDIR}"/${P}-py3.11.patch
+)
+
+EPYTEST_DESELECT=(
+ nbdime/tests/test_decision_tools.py::test_build_diffs_unsorted
+ nbdime/tests/test_diff_json_conversion.py::test_diff_to_json_patch
+ nbdime/tests/test_merge_notebooks.py::test_merge_conflicts_get_diff_indices_shifted
+ nbdime/tests/test_merge_notebooks.py::test_merge_inserts_within_deleted_range
+ nbdime/tests/test_merge_notebooks.py::test_merge_interleave_cell_add_remove
+ nbdime/tests/test_merge_notebooks.py::test_merge_multiline_cell_source_conflict
+ nbdime/tests/test_merge.py::test_deep_merge_lists_delete_no_conflict__currently_expected_failures
+ nbdime/tests/test_server_extension.py::test_diff_api_checkpoint
+ nbdime/tests/test_web.py::test_api_diff
+ nbdime/tests/test_web.py::test_api_merge
+ nbdime/tests/test_web.py::test_fetch_diff
+ nbdime/tests/test_web.py::test_fetch_merge
+ nbdime/tests/test_web.py::test_offline_mathjax
+)
+
+src_prepare() {
+ edos2unix \
+ setupbase.py \
+ nbdime/tests/conftest.py \
+ nbdime/tests/test_cli_apps.py \
+ nbdime/tests/test_web.py \
+ nbdime/webapp/nbdimeserver.py
+
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=( --skip-npm )
+}
+
+src_test() {
+ # user.email and user.name are not configured in the sandbox
+ git config --global user.email "larry@gentoo.org" || die
+ git config --global user.name "Larry the Cow" || die
+
+ distutils-r1_src_test
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}"{/usr,}/etc || die
+}