summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 19:06:53 +0000
commit427aed27427f356a75db3288d7b96ce7e2a044b2 (patch)
tree259ea4d9db267c160cbae0bdd575dcd349d23d8b /dev-python/nbconvert
parenteb72a69c0109ff53b8c18b2f6c3b160489376e2e (diff)
gentoo auto-resync : 11:01:2024 - 19:06:52
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.14.1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index b18e45893b27..c95ce3f65a05 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,5 +1,7 @@
DIST nbconvert-7.13.1.tar.gz 851593 BLAKE2B aa9895257710b2e759c25f91723a69cdd1a4c27e7910c423ed8818497ae78d6a5896dc23333bc312a51d022d3de51a3afc0aecfc03e5ae9814dcea508b79e928 SHA512 33fd1bd41ea4b321875ac6a698b1bfd61e69ded672ee0e7ba4d1dd0a5bff7150f56f18f68212dd4a9e997c9642d83c237354fa8a5a62be492d8a292440cbc2d4
DIST nbconvert-7.14.0.tar.gz 851778 BLAKE2B dcad57a56b1d7070188eb864668e1a12f26fb45ad88b0c566b26bc262bef250559bc4e011280c792d82c614330f38816f5f8fc9c3035d5d218aff8c312b78df6 SHA512 140c335c1ad5fa8419f273d102e2f39179edadff96caaba78f3b87118ee7690dee2978981d972ddd06ed3a67182f7d24467f8d0ad44760d1f0d74a2f5dd7ac35
+DIST nbconvert-7.14.1.tar.gz 852119 BLAKE2B 22248b507220e7fc71fca95a2d43646c9365adc89ec89c2f840705937f2715a070c2d509301cf9252fd0489e2041f0c6f1df38c928ed5e449a3674a2f1639873 SHA512 91e29460f746ad6a9db898e27de755c469ba0011d21737f2149d8475c9dcc4442178802b79f890424666d81108a416c1727eaf3de7db13370713ec9cd9b77262
EBUILD nbconvert-7.13.1.ebuild 2392 BLAKE2B d50661b4074266d6dac01a5e26b7a32a995e00ad54157ca45ed0d6c225e176de4f9d01dce2edb51268f43f3f805c7998d5f951b83f0dc8754031577350659e49 SHA512 4c19ebb4e286c242800da3a3780bd6dca8e832d030d441f4bd76e49ae13ae068e204c5c0c80fa93ffdd51a2ca19b4d51ef5c1bbbc05128e4dd9ab8f2ce8dcf5c
EBUILD nbconvert-7.14.0.ebuild 2400 BLAKE2B 0fe5ee3cba06a2ebbbafa71b033c5cd64a14f18b8830644a4982eaa9def676b2d29511db3a91c6ed4d4d2879fc9fdb9925fc721510ea1aa92eaf0c781bb7305f SHA512 69d42b858bef1beefc62e7eab3a599e104d851a006fc3214fd381c734e2e56b1cfc8f5945ac03c4f4431c051a284eceecb59912282fe77d2496b0b61a8791d08
+EBUILD nbconvert-7.14.1.ebuild 2155 BLAKE2B edb577b81b84f063690f5c8243a558c5964acc154f056883c9c70320c99f61fef3c3ca97c1373acac0129ce0bf1dd639538b179cc97416b71df57551935f03e6 SHA512 1158f3b3cfe7f77dc939abb399cf36e79fbf99623ff333ec541f6ac3371247ccacc5a0a9c3ff1f6dd1cab4a529395a61e9ffe190e7d56610d1cd408378e60585
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.14.1.ebuild b/dev-python/nbconvert/nbconvert-7.14.1.ebuild
new file mode 100644
index 000000000000..0e4d228d0bea
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.14.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.5[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}