summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
commit3f5490a92f684d302af15210584c70ed8ea3fab4 (patch)
tree641a95536c4796f995e98f72b6c4cc833c94bfac /dev-python/nbconvert
parent1b2c0d19f75523db182b267901484f87abf732cf (diff)
gentoo auto-resync : 05:10:2023 - 05:53:25
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.9.2.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 781482f89c7a..45acfc2681c9 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,5 +1,7 @@
DIST nbconvert-7.8.0.tar.gz 850287 BLAKE2B c499f9df8dd7eb4d337f0b7b6f79cb6046361900747fc1cbd84426b2fda35f9e453002341b322b32f04187e0fd3e375dcc4338e3b4bc7455ddc4f2185a69ed1d SHA512 e332f5561050244c79e728c71e51b9ecd66c99c1550bb95bc3cb710b1bb67a3513c0a7c00cb3e333c032e5228f251b7be036162c77cb375900c5eacc923fc197
DIST nbconvert-7.9.1.tar.gz 850278 BLAKE2B 718eb528911c85f7a60285590fdf6d0bea6b9f6a11b9764506cfeb46ace20b32582947a7f63f7c1a8c3d631cc2b032a683cabcad9f52414a260a05acc717d1dc SHA512 d50cec9fdb89d1b6e31fe24aa9146207aea86438b96d8f7a5d9ee4d18f41f0c53ae1855e0701d2ddceb00b5e97bf849c63790a674ac2346546ab7285ee3c9a6e
+DIST nbconvert-7.9.2.tar.gz 850333 BLAKE2B d2d2b6f04e879a78151e606c24b03dd4655b37cc13a1302d7d7a8fd880d9728f0a144f25aefbfaa4b63d4a510811ee6af6d92cf9506d2c1718d7b319cb7ef745 SHA512 43ed36aae813f77bfd50aebfed4c650e552fc5a438e607b924aa2907f23c53c61ec3ddff1051d77e8b0ad968fcef17e6b010b1e7876b17b380d2e12cfeecf631
EBUILD nbconvert-7.8.0.ebuild 3094 BLAKE2B 27a1afaef7e037799e2b8546e75174dc1f27a9a369dac65539844b5c54a2309ef2d5b011f49eb6b81c732e97ccdfdbc216c4280332bc8e4ab2c0bd354418af83 SHA512 c3bc1eb1ccd9b53f6fb34e2187874b34324e7b84eb1c466157ec9a7b5d8b880a904cba884043252d71f0f95c2060683eb31e2b7bc28cdeb5e4a9e87f95a39426
EBUILD nbconvert-7.9.1.ebuild 2451 BLAKE2B 05f0cf7ca3b6453f7a6f8e5ea0bc758df1a26a1320c90f7d62c8f717a9abe6d577f6c2c01a9d360505ed54b3bf6008560a0c2c180ce041ad548367bea6978f62 SHA512 3606dcb6ae214a9c4e5f58b1ec47952899699ce7c2c26525e8483fa9ebd173379594b842fd4d9e765b18dad0e488b11940908372ce74fd281b2e6e804c75e452
+EBUILD nbconvert-7.9.2.ebuild 2451 BLAKE2B 05f0cf7ca3b6453f7a6f8e5ea0bc758df1a26a1320c90f7d62c8f717a9abe6d577f6c2c01a9d360505ed54b3bf6008560a0c2c180ce041ad548367bea6978f62 SHA512 3606dcb6ae214a9c4e5f58b1ec47952899699ce7c2c26525e8483fa9ebd173379594b842fd4d9e765b18dad0e488b11940908372ce74fd281b2e6e804c75e452
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.9.2.ebuild b/dev-python/nbconvert/nbconvert-7.9.2.ebuild
new file mode 100644
index 000000000000..c3ac4e5d1e50
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.9.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest -n "$(makeopts_jobs)" || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}