summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-01 00:00:05 +0100
commit3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (patch)
treecb6347688c91bfbdebe49a78a55dad3d72cc193e /dev-python/nbconvert
parent4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (diff)
gentoo auto-resync : 01:05:2024 - 00:00:04
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.16.4.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 9eef8705c509..1e627114e0b9 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,3 +1,5 @@
DIST nbconvert-7.16.3.tar.gz 854257 BLAKE2B 77bf80e4e7ed93b3aa3731cf74e84a9e1e588c2a43a6d83dafd3511690fa2e9e040344251d4544c0e4e7e1546907be31d065d7bbce2818abbbc4a41c8d6de15d SHA512 571c56fe172586d0929c986cc40aa42687e30d98cf13ba4053535efe3d0353c4c137ae85d6445038c6611479ea30ed438b91dffdf7e4b145e92ae5e4f450d42c
+DIST nbconvert-7.16.4.tar.gz 854422 BLAKE2B f04a8fbffde70e08736d13a3db3278c9248f742b27688eb56760b9ff46c58aec63aa05a4cff256e5929009c3f76d760ce71209f3c49b40af374f06b073ddd661 SHA512 f9793ce89f18530492e1e9aeba3759ac6ae8aa8e0459be52928689a58b0d816128d275bdf9061ec9f33a047e0b6c8d4d83e5a81da556700e0add48374f15fcd8
EBUILD nbconvert-7.16.3.ebuild 2129 BLAKE2B c985ceeaa9b95b9c4404cdab39009e13d3b1873e96fcd351237a0e07642fb845900035bdfe8d1e1f7d27c51a58d5d1f74442cdf9346c47f0b3732f7c89cbe313 SHA512 8954d7e0a0a8a5a139c2b6ffb19185061db8fa51e7b77a4ac9bedb1e83326722a599f05b1cc0486a9b81af380d4ab36eb98a5c3580f771678cfacfb327b88a94
+EBUILD nbconvert-7.16.4.ebuild 2136 BLAKE2B 977df81ed6e32340d84d104efa8969b83a876e96aed32600151a31ef2c6cb1d692002481718472f6ae4ed2b16d1635bd69d5bdf7d0b068c3a2836c48df728140 SHA512 005f516a9011e128e8b867315fc1ddbc57b615d7ff11d51fe21bd73068b1bff5b1f7df2898450a545516fee35e11c0d64db2d8b34634f92bc41c659826bdeedf
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.16.4.ebuild b/dev-python/nbconvert/nbconvert-7.16.4.ebuild
new file mode 100644
index 000000000000..90b36a68a170
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.16.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7.5[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}