summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /dev-python/nbconvert
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'dev-python/nbconvert')
-rw-r--r--dev-python/nbconvert/Manifest2
-rw-r--r--dev-python/nbconvert/nbconvert-7.11.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 62f9dc56b5bb..79fdfff245f2 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,5 +1,7 @@
DIST nbconvert-7.10.0.tar.gz 850541 BLAKE2B ab0fbe4ab21c123dacfca5780c108b158c09db1046c999ccf07e0f3621e9d50ebf900df5df9b531aae76b53f283179fcb659a37d5a72c7713e37af48b10ed300 SHA512 b04bd5a20b9284fbab66e6bd8aa165d07e2a2dba51c478e421eae67ec9ac139e2bbc5bc1eec15b7ad23757125747016abc8de0de905794af142523f1ee0683c4
+DIST nbconvert-7.11.0.tar.gz 851158 BLAKE2B 0506acda6a645ffba6771f600c63f0c37705481021b716a2b5ec61b49f2b9da490beac7a1fec67718d091d7bfcf82d7f07b68e207573ca5c08271fc502214eb1 SHA512 097e740413520b943afea11e2b797fbb163e1c34b79932597ec1c5a2c64bbb9342e4b3e1f0ab7e4d6dbdaa736d747650d8e0e50da0e4db5398151da8c3b57c59
DIST nbconvert-7.9.2.tar.gz 850333 BLAKE2B d2d2b6f04e879a78151e606c24b03dd4655b37cc13a1302d7d7a8fd880d9728f0a144f25aefbfaa4b63d4a510811ee6af6d92cf9506d2c1718d7b319cb7ef745 SHA512 43ed36aae813f77bfd50aebfed4c650e552fc5a438e607b924aa2907f23c53c61ec3ddff1051d77e8b0ad968fcef17e6b010b1e7876b17b380d2e12cfeecf631
EBUILD nbconvert-7.10.0.ebuild 2451 BLAKE2B bd7443d2459d26c9aca5df3de60c42a8e41a3f488aa9ae720df0e7587df3e2998e74612df56b03ea900150913ec8511db588a2c1ffafbd8f5f09f25829646cd1 SHA512 77b5bbab3a9521a59a354a6759e78336cddb8cb569a204b620d9d103b38b9dcf713fe18b798e530cba138b3f6b82ff1984270f46cba9b6f953720279713b66f2
+EBUILD nbconvert-7.11.0.ebuild 2385 BLAKE2B 499cc5d085b0fee50a24e77ac5783e51684695ac8130cb8de4d9d2fea54268c7133cce631ca403b5ebe8836e8d8597d73f29dc256fa956bb4f537a99437b450f SHA512 b29a348f7bfb805c5b4c2dd0c4f8af2195eaf23968dc1d167ddb40d09fc08666a3f9bd81687a7019faca604d8bb56f88d21c5725b1956cd14fb3880c254e1811
EBUILD nbconvert-7.9.2.ebuild 2443 BLAKE2B dd67b0b4aa7f59e59e1a4cebb8a47582dc34c7ed770b904c416df36b55b860869fdd558b154a7c67eef1631a41aeddd39fa3ce06ffc514372a7105e852d0124e SHA512 ef91998da9ac4da4aa28564d5e8c0f6fe4686509066344ed93d12609b83104ccaede97fbbf2035d53a0885fa6e23ec115faa1f5efead5b0c65947e063ad7bf78
MISC metadata.xml 527 BLAKE2B a915103b3eaf57236f4257c98354a1e3733771369ac825fa8bbc4f79f0d1a23272dc86e744513620fbee37792e813a15dbb955e633a7c57597c3c38657ed05d3 SHA512 b60a311ce52915dbc12addd4a882670ac96ff8b3be2aa651eaac3d0963d6e73a72eaafd53f90fb685599504857e6bcd0568071962d7696c2605462b77260ad6a
diff --git a/dev-python/nbconvert/nbconvert-7.11.0.ebuild b/dev-python/nbconvert/nbconvert-7.11.0.ebuild
new file mode 100644
index 000000000000..03f935b8be1a
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.11.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab-pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ <dev-python/mistune-4[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.7[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # crazy qtweb* stuff, perhaps permissions
+ tests/exporters/test_qtpdf.py::TestQtPDFExporter::test_export
+ tests/exporters/test_qtpng.py::TestQtPNGExporter::test_export
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest || die
+}
+
+pkg_postinst() {
+ if ! has_version virtual/pandoc; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}