summaryrefslogtreecommitdiff
path: root/dev-python/nbclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
commit955b5fcaf4acc77c39a1f145d7c56e99f13083a7 (patch)
tree1141703ebc6ca24ff935b991e261d716a5d98243 /dev-python/nbclient
parent24c53d42e0294f4f6e36fbb051891af86c9ae503 (diff)
gentoo auto-resync : 23:05:2023 - 08:58:35
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest2
-rw-r--r--dev-python/nbclient/nbclient-0.8.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index e9fbe64a253d..311766626491 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,3 +1,5 @@
DIST nbclient-0.7.4.gh.tar.gz 79167 BLAKE2B 90b61c55cf25aaa2fed8fd914d799619fefb1353826f7a41320efb732ccf7a44efce944c03d472f9f441a1693bfcdce76e23d0746d62c020e996dc55de7be2b6 SHA512 24cdb1d8b9ffc4899f15490f15d5a41a3e62c52c2b57d8ee768dc93fda08bb6f1a432306a551ece3d031061f790e032c765b0d96225700b2820ca59bc71e9aeb
+DIST nbclient-0.8.0.gh.tar.gz 79287 BLAKE2B 5147195fa75ae5da620eb44b5b3d360f69275f1590d098757c6f460769bdb62d3eca576a344861e382bf430f97159adbfff46f557c3509d5fe06d269a0302cdc SHA512 f77ecba2f03a8886e8a2335e1d345fcc1d3a1726b458d151a8c78b85c621017cd96f1ef30e4532bf61b89c92aea128a364f5e9677858951f5d070c6206a01816
EBUILD nbclient-0.7.4.ebuild 1574 BLAKE2B 70e9e82893cb827debc8ae68c2c771854a8a1dda62cb1ebb7dad7165e250eafa6a60d75e068f523f3ae2e2727886fc441c1659f03f9a5c803a4ecc3e13ad4ffa SHA512 bd853c70594477007cb9a9950f7a379d4df569499afc4b9d293f5cd054321a067aa61b02d54aa9d0b424172150a66fa5cba7950ce47eafee5f02141708c768fe
+EBUILD nbclient-0.8.0.ebuild 1592 BLAKE2B 59108a8b00a27bfc40bc4f655bb51cb086f1ca9ea5e825cefcc14d7ba52664b96c0a7af7d864865f401531337ee15823fb6f8b5d9728bd466082f1f84fe332ae SHA512 7d80f6c0ba1d97591b8f3fe08a477af08e257cf34fcf563cdf04002396fd5e6dfa498a47add185a2dbd8778259cec2672dff1e0fde160b78a83241d0dfde63f9
MISC metadata.xml 405 BLAKE2B d1efa5f7bb2a959bdbc6093b1bd3930e6cdb9bffbe872c6775c15dfc1024ae24d6bcb4651c8e1fb06242b17d6a86f683de3b528bbf1a60b5656a90c1f4ac81b7 SHA512 5b0de690d37dd5928e3bfd0b380336d154cced094e342b41dfd16d0caddd2b792a2158b209404a36461cf4d1b12d836024eae2aedf15093b90f4e363382b38bf
diff --git a/dev-python/nbclient/nbclient-0.8.0.ebuild b/dev-python/nbclient/nbclient-0.8.0.ebuild
new file mode 100644
index 000000000000..a538de91f03f
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
+}