summaryrefslogtreecommitdiff
path: root/dev-python/nbclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/nbclient
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest3
-rw-r--r--dev-python/nbclient/files/nbclient-0.10.0-py313.patch35
-rw-r--r--dev-python/nbclient/nbclient-0.10.0.ebuild7
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 3346c32e2f78..f353a3f1b89c 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,3 +1,4 @@
+AUX nbclient-0.10.0-py313.patch 1379 BLAKE2B 3dc2b408b3343b0200244ac33691857347f5fbfcb4543bb25077c4d353e06ec4050439ee45ae8582b62da2805aeba1aeaf4c3dca5b0a4011c78bc30f646150d7 SHA512 08d20f2366229fc44e0fc4356c49e61b45ba075d293606d6eec4a4d1f9a6da4876f6f300d6279969432810fdae97c1491682eef8f6d96d030299e1278148d599
DIST nbclient-0.10.0.tar.gz 62246 BLAKE2B 4fdbbceb6f37c0f96a448c343d910c8ac988ed337590c9f8068eee328fbc7f58c882b15a8b0f7fe03491a8751512ad76497d3a0e8a19783ef24001acd901bd67 SHA512 1635c8af91839b9e651fbada7aca3699ebf92c0f4f7f47d9901f9977f56f2b31113c1229d1512bdb200c6c729e1e965649031729a60229d463e6b39f75ac9dc2
-EBUILD nbclient-0.10.0.ebuild 1337 BLAKE2B c5a7cc257a516e9b752d34bfc8e3ec481e3a35cc8508257402a5b11b1661b25e91f6704177f3b2815d8c40db97ead6a6b25368f0f29e95ab2a5dfd7b07e422c7 SHA512 1e587407b71d892e0f7b94fa64aaa6ea7e925a95ea3eaebf94f8a3a14546cc66d460b4ac1e6a766b133c96bc1ebe8b2f4810b953109c327ebfec68603ea91bc8
+EBUILD nbclient-0.10.0.ebuild 1430 BLAKE2B e9bf2f3343f4b978ebea5f558e5c876f599cc1611c03604cfed93e13fb35a3e61e730561dbd78347382e31d40fb280942d51485699da8af9c6f2bd763568d820 SHA512 705bc158c9a024a2b22cf013adf9f330ac9821304e11c55928164bd8bec109ad4aa68350ae82e4b98791f6edb3234a17eeaf906456478ec41a8d1d8ca0d0e5ff
MISC metadata.xml 405 BLAKE2B d1efa5f7bb2a959bdbc6093b1bd3930e6cdb9bffbe872c6775c15dfc1024ae24d6bcb4651c8e1fb06242b17d6a86f683de3b528bbf1a60b5656a90c1f4ac81b7 SHA512 5b0de690d37dd5928e3bfd0b380336d154cced094e342b41dfd16d0caddd2b792a2158b209404a36461cf4d1b12d836024eae2aedf15093b90f4e363382b38bf
diff --git a/dev-python/nbclient/files/nbclient-0.10.0-py313.patch b/dev-python/nbclient/files/nbclient-0.10.0-py313.patch
new file mode 100644
index 000000000000..1403cd0e0513
--- /dev/null
+++ b/dev-python/nbclient/files/nbclient-0.10.0-py313.patch
@@ -0,0 +1,35 @@
+From 57222265bfd8bdcf8851997e1dce5cd564e1a573 Mon Sep 17 00:00:00 2001
+From: Lumir Balhar <lbalhar@redhat.com>
+Date: Wed, 3 Jul 2024 14:21:41 +0200
+Subject: [PATCH] Fix compatibility with Python 3.13 beta 2
+
+There are more calls in 3.13 than in previous versions
+so the tests are now more permissive.
+
+Fixes: https://github.com/jupyter/nbclient/issues/316
+---
+ tests/test_cli.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_cli.py b/tests/test_cli.py
+index 04b9887..55ccbd6 100644
+--- a/tests/test_cli.py
++++ b/tests/test_cli.py
+@@ -60,7 +60,7 @@ def test_mult(input_names, relative, inplace, jupyterapp, client, reader, writer
+ # add suffix if needed
+ paths = [p.with_suffix(".ipynb") for p in paths]
+
+- assert path_open.mock_calls[::3] == [call(p) for p in paths]
++ assert all(call(p) in path_open.mock_calls for p in paths)
+ assert reader.call_count == len(paths)
+ # assert reader.mock_calls == [call(p, as_version=4) for p in paths]
+
+@@ -114,7 +114,7 @@ def test_output(input_names, relative, output_base, jupyterapp, client, reader,
+ # add suffix if needed
+ paths = [p.with_suffix(".ipynb") for p in paths]
+
+- assert path_open.mock_calls[::3] == [call(p) for p in paths]
++ assert all(call(p) in path_open.mock_calls for p in paths)
+ assert reader.call_count == len(paths)
+
+ expected = []
diff --git a/dev-python/nbclient/nbclient-0.10.0.ebuild b/dev-python/nbclient/nbclient-0.10.0.ebuild
index 927821177ce1..2ae636b41d3d 100644
--- a/dev-python/nbclient/nbclient-0.10.0.ebuild
+++ b/dev-python/nbclient/nbclient-0.10.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -41,6 +41,11 @@ BDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/jupyter/nbclient/pull/317
+ "${FILESDIR}/${P}-py313.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# hangs?