summaryrefslogtreecommitdiff
path: root/dev-python/nbclassic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/nbclassic
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest2
-rw-r--r--dev-python/nbclassic/nbclassic-0.3.3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index 2e2c5325494f..905af391559b 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1,3 +1,5 @@
DIST nbclassic-0.3.1.tar.gz 25761 BLAKE2B 0bdb02d68dd73283cf228c7a4964592ebea9884f9f68571d5ea3715a44236cab1dd68f7e42fe62f82f18f5937a55c3f222bffed5be2b4e8b31c596e6c357e28f SHA512 351aa10652f286a2a6be68d8331b24f200138bd65c777884b1a70aa9d991da0a39a4bc77eefb6f74e47edf708653780d81a3805c28dffb43d32716998e4c38f5
+DIST nbclassic-0.3.3.tar.gz 21924 BLAKE2B 382d41c2eeb6ffc9588b80c0bc84e7e8b581fc36f2628d46577ca0a6956c50086a7b9a3bccb1c318fc60169a0367c8c5e1c6bba56b0a35fa063768f8fa580d52 SHA512 74b765c842351b2a93e92850193db7d3ef1a0b11c0c25a9adb2d1b8f7a6f88ae083cc700cda004d874340443632e738a24d26349d661613a707ad6cc42abd709
EBUILD nbclassic-0.3.1.ebuild 652 BLAKE2B 1b320e7e52f2809da919cd4fb174dcd80a91688fb445ba3d48abc7ce73373adc87cc4a269341f326daca7b047a200e72f7115a8951672f348628e812cd709df2 SHA512 1eeacf987f46bd1bf3bc6239c7ac0fef16abf63f205fe778e1b87f5d42dd82aa97e6688da074dbee248d4e996f79ae9736cc8e57631d90bcc9a6c2ce2b41f4c4
+EBUILD nbclassic-0.3.3.ebuild 961 BLAKE2B 9a76fe1b6414b64c5b47647d58452475b6efd28a052a7b9fe6c480f0715ed078b59c411ff89e7acfe6172cf239be64b0f0dbc55da1ce6ba58202f1c879bc2436 SHA512 1fdb2a3175fee83e53225e05ded32cb751ded41347322530ae063bc6d6037d78048d220a9cc9decddecb53c69d55ae5ee65fcc1ff3d28c4dd4bfc9d17adbdfa4
MISC metadata.xml 410 BLAKE2B 0b5a5047ac30e2bfc7f85fa8d5243dc4d90f21b3ba4cfa88e6dfa08d8a063a49fd962650424521a436963a40cd4d2b54ca15326f29aebd3df158c4985d94cd26 SHA512 3ce674ac4b73cd15fba38ea29f8064ce2a5c5b77ae58cb0b046a1b9b9263a3149674a5e24d96f3517d6a5fc2cfd13d5de15090ac40aec4865ec0626e91b28723
diff --git a/dev-python/nbclassic/nbclassic-0.3.3.ebuild b/dev-python/nbclassic/nbclassic-0.3.3.ebuild
new file mode 100644
index 000000000000..727c1391b449
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/nbclassic/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv ${PN}/conftest.py . || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}