summaryrefslogtreecommitdiff
path: root/dev-python/nautilus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-python/nautilus-python
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-python/nautilus-python')
-rw-r--r--dev-python/nautilus-python/Manifest2
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.2.2.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
index 5b54f07f0a48..f2c26ead09e2 100644
--- a/dev-python/nautilus-python/Manifest
+++ b/dev-python/nautilus-python/Manifest
@@ -1,3 +1,5 @@
DIST nautilus-python-1.1.tar.xz 239392 BLAKE2B a2baef3cb4d96d97b4b3e9b7644388c8778e1579ee0b32ff2a60baae45baa2d60dbcc61108fc3fe9e8a7193cf4c6ad82f8ffc2f175419e0937bacecc98551c51 SHA512 e721f46414a3efa4b5f5ec3f56cc00a308ec010a7a0612cef975d6f436494701f8bdbed39bdb5186c8013a582c7e63288a1c60adc4b8967c9ec69d6301a50fef
+DIST nautilus-python-1.2.2.tar.xz 269220 BLAKE2B 9f2b5acc20727acf4464297bc008e8be0bb45ed418601e3658405e90eb3d56306f9aece402948491d5423d58cd261cee5cacbd39dd185957c4d72c90f877842e SHA512 541ab9e6ac15b06994cf475237e5588d21f4b9f71bb562f4bd9d976f79849a29912080de0b16c14406b052bec15c2c754381bf36e15b340d1f8e76c83a2464bc
EBUILD nautilus-python-1.1-r2.ebuild 1256 BLAKE2B 85b87fecbbed7bf55cf7c8d53e2a8d5267037495698ef45646d43edf6658d2f71a1ae1c71c66860c0d36f49ba47a39248c6f6a9f8a272e048414d5a1ac08b642 SHA512 40b29c0099b7d5d5d6730918ef263e522cd503ea7e77111a80361cb496b74a65a1bdbb5fb879beb85c3806a0e8ec4a1aeb77ea3fc3bbd2344ce5292eb4fa8448
+EBUILD nautilus-python-1.2.2.ebuild 912 BLAKE2B 7dac3951975adb80f95ec62d4fa086f1fc3067d2409aaae25ffea5f2627d7b2324b2e90d80ae4b54fedd6b567308d508f22d739076467d12377cef2e1c85add0 SHA512 9f7e4c4cad425ee3c67f5c467994b63744739b4275cfd285367826854895b90111236db10a36f30050e60ebc03e207876f470af6b301f31ceb8d354bb722f4f5
MISC metadata.xml 256 BLAKE2B 328c05c417050a2312f4b9e62188c1bcf9a694a2136c4c9ed8f31e818c968398458459bc87784157677f0da7a648f5d07c2246563cb5ef534fd9d97232dee982 SHA512 efe3e668ae6d6c6e11e5783c9133fbc6378a4cf21d502aaf7ada64dec0418f457480754a907ac037bb9f7acc008410c6c2f9db57322b9b44256aec74b14ef63c
diff --git a/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild b/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild
new file mode 100644
index 000000000000..291a0ebb6d43
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; configure itself
+# requires pygobject:3 or :2 and >=nautilus-2.32
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=gnome-base/nautilus-3[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}