summaryrefslogtreecommitdiff
path: root/dev-python/nautilus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
commit6dfd9c39ab68bbc917ffc374b2fa515f676f891f (patch)
treec9963a9e1e09b0e237a5c00736caa588c5a0a38f /dev-python/nautilus-python
parentadb727afeb568404873e8cbc91ba93d3d49eff13 (diff)
gentoo auto-resync : 26:12:2022 - 20:08:29
Diffstat (limited to 'dev-python/nautilus-python')
-rw-r--r--dev-python/nautilus-python/Manifest1
-rw-r--r--dev-python/nautilus-python/files/nautilus-python-1.2.3-gcc10-fnocommon.patch147
2 files changed, 0 insertions, 148 deletions
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
index 62aa90b0ac6d..ecdcff86160b 100644
--- a/dev-python/nautilus-python/Manifest
+++ b/dev-python/nautilus-python/Manifest
@@ -1,4 +1,3 @@
-AUX nautilus-python-1.2.3-gcc10-fnocommon.patch 6095 BLAKE2B ca0f7c2f46d3fc265cf2649c3f9f58d8bcf88212cd62065cb6f30adf2094e206eafb48354bc25bcc1afb887703b8d05d2a83020ff6382021edef130d5509ef38 SHA512 267171aadd5fcc825ca42e91f94dba72260017cc0aa4bc12874fef4773d46c6b47c1fc093e5043b3c77161cf2a51b78e6882ac8cc60c800c870d325108ce15c4
DIST nautilus-python-4.0.tar.xz 32184 BLAKE2B cc910de82e54cd687d23541a0b283a70dc5a0626acebf8787110ae1b5a4c080741c0879968816e217a4da968a77169d79b6614dd055f1ae57999a9a49f2553cb SHA512 f70f825b821f266caafd1b347066de01462b8256ec126072042d09dd7fd6c9324847d5ddab65671589d0a411f8b8fed428dbc94806ac679d646861c66c3a0dd5
EBUILD nautilus-python-4.0.ebuild 1180 BLAKE2B e7aa63f73af3db09fc203b23b224450e8e124e8259f4794aa2e603d69b50a7d775721b1de4d0804bc65ec374a55eb181a32802fdd2191dfbdbaba7f3089ba11a SHA512 e33fb968da213639d46ef6c9ee85c894d7bf89fae57c43a4d1cc5e90d2e44132276e963f984c226d80745e8ffd73eb1eff8d4d995d620eead7ba60f1eba776cf
MISC metadata.xml 356 BLAKE2B faf70d4fbe0451757ccedb3d4c316fd8d4528adc79a559eabb3e8e55e026729d20bcef8113d35d3c0e6f4c17ba36eeae4230cff1876f5c8c2d4ce9a4ba0f9881 SHA512 a17c4dbc5f2f06617086a7b5a9c82eede6236cca667f5fe765ece5eaaba9a909aec03234bd93cab339c0449465df41aade9ac4176a70ab95218485fdf4705a72
diff --git a/dev-python/nautilus-python/files/nautilus-python-1.2.3-gcc10-fnocommon.patch b/dev-python/nautilus-python/files/nautilus-python-1.2.3-gcc10-fnocommon.patch
deleted file mode 100644
index 7e0f760aca2e..000000000000
--- a/dev-python/nautilus-python/files/nautilus-python-1.2.3-gcc10-fnocommon.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-From bd4820186751034c6b5acb9c71b1aeab03c56523 Mon Sep 17 00:00:00 2001
-From: Andreas Henriksson <andreas@fatal.se>
-Date: Mon, 11 May 2020 14:57:45 +0200
-Subject: [PATCH] Fix build with gcc 10
-
-Bug-Debian: https://bugs.debian.org/957578
-Forwarded: https://gitlab.gnome.org/GNOME/nautilus-python/-/merge_requests/7
-Last-Update: 2020-05-11
----
- src/nautilus-python-object.c | 10 +++++-----
- src/nautilus-python.c | 13 +++++++++++++
- src/nautilus-python.h | 22 +++++++++++-----------
- 3 files changed, 29 insertions(+), 16 deletions(-)
-
-diff --git a/src/nautilus-python-object.c b/src/nautilus-python-object.c
-index f343070..da185ad 100644
---- a/src/nautilus-python-object.c
-+++ b/src/nautilus-python-object.c
-@@ -40,7 +40,7 @@ int __PyString_Check(PyObject *obj) {
- #endif
- }
-
--char* __PyString_AsString(PyObject *obj) {
-+const char* __PyString_AsString(PyObject *obj) {
- #if PY_MAJOR_VERSION >= 3
- return PyUnicode_AsUTF8(obj);
- #else
-@@ -389,7 +389,7 @@ beach:
- #define METHOD_NAME "update_file_info"
- static NautilusOperationResult
- nautilus_python_object_update_file_info (NautilusInfoProvider *provider,
-- NautilusFile *file,
-+ NautilusFileInfo *file_info,
- GClosure *update_complete,
- NautilusOperationHandle **handle) {
- NautilusPythonObject *object = (NautilusPythonObject*)provider;
-@@ -408,12 +408,12 @@ nautilus_python_object_update_file_info (NautilusInfoProvider *provider,
- pygobject_new((GObject*)provider),
- py_handle,
- pyg_boxed_new(G_TYPE_CLOSURE, update_complete, TRUE, TRUE),
-- pygobject_new((GObject*)file));
-+ pygobject_new((GObject*)file_info));
- }
- else if (PyObject_HasAttrString(object->instance, "update_file_info")) {
- py_ret = PyObject_CallMethod(object->instance,
- METHOD_PREFIX METHOD_NAME, "(N)",
-- pygobject_new((GObject*)file));
-+ pygobject_new((GObject*)file_info));
- }
- else {
- goto beach;
-@@ -434,7 +434,7 @@ nautilus_python_object_update_file_info (NautilusInfoProvider *provider,
- #endif
-
- beach:
-- free_pygobject_data(file, NULL);
-+ free_pygobject_data(file_info, NULL);
- Py_XDECREF(py_ret);
- pyg_gil_state_release(state);
- return ret;
-diff --git a/src/nautilus-python.c b/src/nautilus-python.c
-index 843e3c6..510cdfb 100644
---- a/src/nautilus-python.c
-+++ b/src/nautilus-python.c
-@@ -22,6 +22,7 @@
- #endif
-
- #include <Python.h>
-+#define NO_IMPORT_PYGOBJECT //To avoid a multiple definition, nautilus-python-object.c also includes and does the import.
- #include <pygobject.h>
- #include <gmodule.h>
- #include <gtk/gtk.h>
-@@ -42,6 +43,18 @@ static gboolean nautilus_python_init_python(void);
- static GArray *all_types = NULL;
-
-
-+PyTypeObject *_PyGtkWidget_Type;
-+PyTypeObject *_PyNautilusColumn_Type;
-+PyTypeObject *_PyNautilusColumnProvider_Type;
-+PyTypeObject *_PyNautilusInfoProvider_Type;
-+PyTypeObject *_PyNautilusLocationWidgetProvider_Type;
-+PyTypeObject *_PyNautilusMenu_Type;
-+PyTypeObject *_PyNautilusMenuItem_Type;
-+PyTypeObject *_PyNautilusMenuProvider_Type;
-+PyTypeObject *_PyNautilusPropertyPage_Type;
-+PyTypeObject *_PyNautilusPropertyPageProvider_Type;
-+PyTypeObject *_PyNautilusOperationHandle_Type;
-+
- static inline gboolean
- np_init_pygobject(void) {
- PyObject *gobject = pygobject_init (PYGOBJECT_MAJOR_VERSION, PYGOBJECT_MINOR_VERSION, PYGOBJECT_MICRO_VERSION);
-diff --git a/src/nautilus-python.h b/src/nautilus-python.h
-index 4c181f8..c940a06 100644
---- a/src/nautilus-python.h
-+++ b/src/nautilus-python.h
-@@ -43,37 +43,37 @@ extern NautilusPythonDebug nautilus_python_debug;
- #define debug_enter_args(x, y) { if (nautilus_python_debug & NAUTILUS_PYTHON_DEBUG_MISC) \
- g_printf("%s: entered " x "\n", __FUNCTION__, y); }
-
--PyTypeObject *_PyGtkWidget_Type;
-+extern PyTypeObject *_PyGtkWidget_Type;
- #define PyGtkWidget_Type (*_PyGtkWidget_Type)
-
--PyTypeObject *_PyNautilusColumn_Type;
-+extern PyTypeObject *_PyNautilusColumn_Type;
- #define PyNautilusColumn_Type (*_PyNautilusColumn_Type)
-
--PyTypeObject *_PyNautilusColumnProvider_Type;
-+extern PyTypeObject *_PyNautilusColumnProvider_Type;
- #define PyNautilusColumnProvider_Type (*_PyNautilusColumnProvider_Type)
-
--PyTypeObject *_PyNautilusInfoProvider_Type;
-+extern PyTypeObject *_PyNautilusInfoProvider_Type;
- #define PyNautilusInfoProvider_Type (*_PyNautilusInfoProvider_Type)
-
--PyTypeObject *_PyNautilusLocationWidgetProvider_Type;
-+extern PyTypeObject *_PyNautilusLocationWidgetProvider_Type;
- #define PyNautilusLocationWidgetProvider_Type (*_PyNautilusLocationWidgetProvider_Type)
-
--PyTypeObject *_PyNautilusMenu_Type;
-+extern PyTypeObject *_PyNautilusMenu_Type;
- #define PyNautilusMenu_Type (*_PyNautilusMenu_Type)
-
--PyTypeObject *_PyNautilusMenuItem_Type;
-+extern PyTypeObject *_PyNautilusMenuItem_Type;
- #define PyNautilusMenuItem_Type (*_PyNautilusMenuItem_Type)
-
--PyTypeObject *_PyNautilusMenuProvider_Type;
-+extern PyTypeObject *_PyNautilusMenuProvider_Type;
- #define PyNautilusMenuProvider_Type (*_PyNautilusMenuProvider_Type)
-
--PyTypeObject *_PyNautilusPropertyPage_Type;
-+extern PyTypeObject *_PyNautilusPropertyPage_Type;
- #define PyNautilusPropertyPage_Type (*_PyNautilusPropertyPage_Type)
-
--PyTypeObject *_PyNautilusPropertyPageProvider_Type;
-+extern PyTypeObject *_PyNautilusPropertyPageProvider_Type;
- #define PyNautilusPropertyPageProvider_Type (*_PyNautilusPropertyPageProvider_Type)
-
--PyTypeObject *_PyNautilusOperationHandle_Type;
-+extern PyTypeObject *_PyNautilusOperationHandle_Type;
- #define PyNautilusOperationHandle_Type (*_PyNautilusOperationHandle_Type)
-
- #endif /* NAUTILUS_PYTHON_H */
---
-2.26.2
-