summaryrefslogtreecommitdiff
path: root/dev-python/natsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
commite4cd098fab4f141df4d2fd24dfdc9b5f223c694b (patch)
treec8abdb0925677514b0f735dbb8f19255088ae694 /dev-python/natsort
parent7d4e34d0bcf06b357fd09a059a02687acf335132 (diff)
gentoo auto-resync : 21:06:2023 - 07:18:34
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/Manifest2
-rw-r--r--dev-python/natsort/natsort-8.4.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 1fd1221db925..c5a36db95590 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1,3 +1,5 @@
DIST natsort-8.3.1.tar.gz 123736 BLAKE2B 3ad4d8884b463fa792f7930f6d92dda146c96cd929a58a1d418c59f8b3c5fc06329e2cf0341963c820fb8d2fc67b287ce69083a2cba9f20bd8abc06c0fca6a44 SHA512 98ee9bfed9307487b9ae9ced5ce723b6840c6f882d06702f205986430572b767f3ac0930ffdf0663d99256f6feed704394b2b7e11f4b01f4f0241cd8639df622
+DIST natsort-8.4.0.tar.gz 76575 BLAKE2B 924058bd0770866d7945edc7886c5d517bf6c886b85c09f7fb0c3f4e7e7e3678993b62bf905245569e36a4acc6437f80e8671f928837d5708d1fe318c7b83320 SHA512 a005abc0fe7ccbb58d1926698a841d90f7f3eac72f062044a6716f0676e0b0766f3e7e14867fb2a0ff1124deaf9796d096744d68b2f6eea001841abed49345c8
EBUILD natsort-8.3.1.ebuild 710 BLAKE2B 99b3ffe8aff0a92df233f020c733d48670c142bad8e6ed878b55e5b3bb826c811523571c78fa9193a7943392b47d141d0e373bb8a3ea21dd30734d49984d20ba SHA512 a717222798ade498d1f33eb048db5a4785f4d027a7f4abe5627929271956acecfeaf83c82ff6014ba96b8fc5cf978c6a990376a62991473c82bd0f7650c9133e
+EBUILD natsort-8.4.0.ebuild 718 BLAKE2B 01d7bb4e76724162d6d6709cabfd4469a4d905fb03e2a39fe21c4c651b1417e0ff87171037e8a7335dac63a4980e62605cdcdfcb368ecbcdd4ca04711436d613 SHA512 f68f305cc4191291bddd0daaf3a1ac1be4d580258028382cfc9a124052b16d0356d7aa06f25ead848680874943218f8dc95058728df86a24389280f0530c315c
MISC metadata.xml 407 BLAKE2B 385c6b60eff44662eee4337cbcc1f57cd7f1f30f129cb6a22e284ebc7bcbd2e5ae271c27b1b0405b3b4087df72494e3b447bfa1cf84f116befb2811c362ea4a3 SHA512 0c91866fb63b5b74f00a28dfb6bf1afde8b8a48ca830bd6bce7a2f8fcfd80982c51fb20913c467fc44c11f3a8c7f69e8544d21dbcb941b2e80cd8690561b07aa
diff --git a/dev-python/natsort/natsort-8.4.0.ebuild b/dev-python/natsort/natsort-8.4.0.ebuild
new file mode 100644
index 000000000000..41ce1f1d5f5e
--- /dev/null
+++ b/dev-python/natsort/natsort-8.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="
+ https://github.com/SethMMorton/natsort/
+ https://pypi.org/project/natsort/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}