summaryrefslogtreecommitdiff
path: root/dev-python/natsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 14:07:48 +0000
commitadb727afeb568404873e8cbc91ba93d3d49eff13 (patch)
treed86cdceda93a48d792f162c7b5f054f09c41ee73 /dev-python/natsort
parented94061721073b4f7b546c30ae337f5737939985 (diff)
gentoo auto-resync : 26:12:2022 - 14:07:48
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/Manifest2
-rw-r--r--dev-python/natsort/natsort-8.2.0.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 5dc39e635abe..fb90b6bcaa65 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1,3 +1,3 @@
DIST natsort-8.2.0.tar.gz 145643 BLAKE2B d101ae2fa1cb009892e9712ece87d3825f3fca7970475e46176e5acbc29481ac79d491f1bae0721d85d3e67ecf39e5f54e2a984f0398356f32a5f0ec18a3e98d SHA512 d7e35c48ee36e69812c26b2cd333c57f1ec70c54017c4f51ed06dbb7619afc11cd1d589035faee700e1adf1e6b759b43ee497685fc88518be62c41957e15884e
-EBUILD natsort-8.2.0.ebuild 705 BLAKE2B e13b0e9110e9386d9e74925647f2954c1186b5c3df5efe0137c1dfae87e558eda5d75608447e3ee3aa28db5b070085ceeaa19a50cb66b1d88c363a79956840e6 SHA512 7e54c4650b2ad934757e8923bda01b080520327b7fcdf4e2e6758fe7db7b06c9110307a072dc3dbbd67c0c04773afe1ae3d3ae843f7591193e6fdbc2123c884c
+EBUILD natsort-8.2.0.ebuild 756 BLAKE2B d6b295c103240a2e2fc9ca59ff979d384a874173819588028d059d66367057b26ba4c846993ecb91f835c6e9c515f136ebee5c13508a6d74fa345c540013571f SHA512 f99b9621a1a5a1fc87edb1f215adc076eba128c84f76bc570b28f80f1fec151f03899a1d05893bcde1f6468bb80df319664d94ed4ccc91408a28bc89fafb4bf0
MISC metadata.xml 407 BLAKE2B 385c6b60eff44662eee4337cbcc1f57cd7f1f30f129cb6a22e284ebc7bcbd2e5ae271c27b1b0405b3b4087df72494e3b447bfa1cf84f116befb2811c362ea4a3 SHA512 0c91866fb63b5b74f00a28dfb6bf1afde8b8a48ca830bd6bce7a2f8fcfd80982c51fb20913c467fc44c11f3a8c7f69e8544d21dbcb941b2e80cd8690561b07aa
diff --git a/dev-python/natsort/natsort-8.2.0.ebuild b/dev-python/natsort/natsort-8.2.0.ebuild
index 564dc064f597..6e12ec517212 100644
--- a/dev-python/natsort/natsort-8.2.0.ebuild
+++ b/dev-python/natsort/natsort-8.2.0.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1 optfeature
DESCRIPTION="Natural sorting for Python"
-HOMEPAGE="https://pypi.org/project/natsort/"
+HOMEPAGE="
+ https://github.com/SethMMorton/natsort/
+ https://pypi.org/project/natsort/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -20,7 +23,8 @@ BDEPEND="
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest