summaryrefslogtreecommitdiff
path: root/dev-python/natsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 10:03:38 +0000
commit24a48769f03b243065aec42c384c39a2d2306964 (patch)
tree6ee4e01247ea4cbdae0b2c9e6b88d86658fae0d3 /dev-python/natsort
parent87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (diff)
gentoo auto-resync : 28:02:2023 - 10:03:37
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/Manifest2
-rw-r--r--dev-python/natsort/natsort-8.3.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 74c9ffa0beba..ce5fde3a5f72 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1,3 +1,5 @@
DIST natsort-8.2.0.tar.gz 145643 BLAKE2B d101ae2fa1cb009892e9712ece87d3825f3fca7970475e46176e5acbc29481ac79d491f1bae0721d85d3e67ecf39e5f54e2a984f0398356f32a5f0ec18a3e98d SHA512 d7e35c48ee36e69812c26b2cd333c57f1ec70c54017c4f51ed06dbb7619afc11cd1d589035faee700e1adf1e6b759b43ee497685fc88518be62c41957e15884e
+DIST natsort-8.3.0.tar.gz 123448 BLAKE2B 7fd480c8bfaceaca7431716e7721acac89d4a5c87a951ecf2754d80062437776eee823d7b94c58e2b9bc6864d9c0f595ee8667c538609c296694a548c126ab58 SHA512 63a65a99c9475e8ae96d722ae4c093cc73034c0dfdd254b24ae02904dd81cc8be36038c8a3fc514080f436d4124847f0f331d06a87c435f0b7b7d1d72313ae0d
EBUILD natsort-8.2.0.ebuild 756 BLAKE2B 6ce476eae7f325ee40e33a983978686137dda8eaf4815f04335638951ab45aaf06578b7561d1584664cdd589b6d485307f11b0a2a93271c51beafe2572e46b19 SHA512 613e2c3c53a6d966e350621c1b838a8bf4bfbbca7c20d3914d504d4a6694907f46722c88c62444c1935140ce3a8c60980aa629f6b37dacad21837433de74771e
+EBUILD natsort-8.3.0.ebuild 717 BLAKE2B b4a491e385d5caeba1b91ebcbf65ff351c719ef46362aceebc80203a43a38a6d3cb4f4e845aa63900d026de0c6fca4dc96b89d86ab6ebbbb7a5ba5a1debdac5d SHA512 8529c3ba92237ca15e55d978412e1cee66ee90939d3077d92e03904180d70cea3cde33c3ab7e7c36b75e730c8699e6ca0f964967b3a259177099bee394901297
MISC metadata.xml 407 BLAKE2B 385c6b60eff44662eee4337cbcc1f57cd7f1f30f129cb6a22e284ebc7bcbd2e5ae271c27b1b0405b3b4087df72494e3b447bfa1cf84f116befb2811c362ea4a3 SHA512 0c91866fb63b5b74f00a28dfb6bf1afde8b8a48ca830bd6bce7a2f8fcfd80982c51fb20913c467fc44c11f3a8c7f69e8544d21dbcb941b2e80cd8690561b07aa
diff --git a/dev-python/natsort/natsort-8.3.0.ebuild b/dev-python/natsort/natsort-8.3.0.ebuild
new file mode 100644
index 000000000000..5b947e1cf1a3
--- /dev/null
+++ b/dev-python/natsort/natsort-8.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="
+ https://github.com/SethMMorton/natsort/
+ https://pypi.org/project/natsort/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "sorting results that match most file browsers" "dev-python/pyicu"
+}