summaryrefslogtreecommitdiff
path: root/dev-python/nagiosplugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nagiosplugin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nagiosplugin')
-rw-r--r--dev-python/nagiosplugin/Manifest5
-rw-r--r--dev-python/nagiosplugin/metadata.xml13
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild28
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild27
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
new file mode 100644
index 000000000000..764a023ed7b0
--- /dev/null
+++ b/dev-python/nagiosplugin/Manifest
@@ -0,0 +1,5 @@
+DIST nagiosplugin-1.2.3.tar.gz 37570 BLAKE2B a6862bde2215c624642a21886eda993f6d3a471bd10ed7c27374617adf7e5ca9d6f82890d21d432018234fe2d803bd01f6e5abf0fc02764f73564a74262eaad8 SHA512 3f3045db181acc144cb41871f2f67090a7b096d600c9cda7e4f9b86648d47319dca7c42b74670ba307c0bc60955eb33aefcde9c895e544bbb4c7ca1f80e8919d
+DIST nagiosplugin-1.2.4.tar.gz 38290 BLAKE2B 4ebf230122a68919f82da7519e920b485075530cbde235d9f0d7a0f22e65a37c85f3ffe84af100f94ba8cee0a8e350b848d2e35606616808baada75c5abfddd2 SHA512 42c7823445c0dc1f5fedc6b8bed6c5be4e2b5e4c14cfa2cfbd158ae43485baa0fc74b80f9dcbb89bfdb27b984d72201c8a7c330c71d837c0f822603a5f8f7ae3
+EBUILD nagiosplugin-1.2.3.ebuild 662 BLAKE2B 94d743f05c369efbbf26b78af3d44d63a4cf11ddf6a731f79517a6e2a6c86f6f1ec66ac9281c43b995ccbaded1120dfef405d32e7d262e99374d587b466a0943 SHA512 1fbc28e9c04f45744b000764571c85bb2bfac923f68df5fcd571ec7fd9af25480ccd614bc895985dc1751bb9d932877b25e74dfdaa0b028c0cd3a22b85b64dd1
+EBUILD nagiosplugin-1.2.4.ebuild 667 BLAKE2B b1a34aba501b963d9838054024b893bb203e1d2839f36b7959836970328ef008fa42ae14f995b063f1c4067d5034b37214a38cd42ec8a24cfe746af3eb3cf54f SHA512 cdba0c309f38289ca1c40e4a659fba19f8735d660b42d71aa60168130ca562032f883a7c3c9377aab12b2bd4266ad3a47e83afe036d43830502eb6b11a4f8518
+MISC metadata.xml 464 BLAKE2B b132f31c8611ba39b42c068d1efce0230f73aca04382ba1089bba09fa03e5f8c83ef8eebbbd74be55d113ece21890d93fdc07b211b538430a154169abe7edef8 SHA512 1476a7d2df7b50e0e908f970fdcfb7a63fa04f2014414e16c4dfa39659846fba26a6808949a741a1cc112edbaa500783db325b2ec5ab66ac72dc2e6152466c75
diff --git a/dev-python/nagiosplugin/metadata.xml b/dev-python/nagiosplugin/metadata.xml
new file mode 100644
index 000000000000..56b0f256a4b0
--- /dev/null
+++ b/dev-python/nagiosplugin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">nagiosplugin</remote-id>
+ <remote-id type="bitbucket">flyingcircus/nagiosplugin</remote-id>
+ <bugs-to>https://bitbucket.org/flyingcircus/nagiosplugin/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
new file mode 100644
index 000000000000..4b912f0d2fd0
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.org/project/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
new file mode 100644
index 000000000000..d605b5b04959
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.org/project/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}