summaryrefslogtreecommitdiff
path: root/dev-python/nagiosplugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/nagiosplugin
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/nagiosplugin')
-rw-r--r--dev-python/nagiosplugin/Manifest2
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild20
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
index d62e07a19e94..44d225024fb3 100644
--- a/dev-python/nagiosplugin/Manifest
+++ b/dev-python/nagiosplugin/Manifest
@@ -1,3 +1,5 @@
DIST nagiosplugin-1.3.2.tar.gz 54262 BLAKE2B af2a8a876105a1ea26671b39d611beaa46303998544adadee3370c6d1b5096fa93160121f89412f3778a2bbc1c3e95606a49413b8f3f0880c9c9ca4e946fb1b8 SHA512 899650852397bffb66ad53843233adec2c91e96656674a9b21c5a02ed97ce4db69c1440d1b88c5799a54745e69b8c05f52188403b5a2fe9050acbd0067806d50
+DIST nagiosplugin-1.3.3.tar.gz 3119586 BLAKE2B e1aecd6f69fc7afe5cbba259191d2ae540efa513ea8f61a263a453ac2b1f6a5d91bbb209d01fc83c72080b54540f7661c04b3485b5cc6c1f9aab44ee2e8fba67 SHA512 edff09b689fd767b9c8ee2ffab30fc63cb740234c830f2f8fef5054e5bc44e945c69858e2374257433b758fb33943a8b148c023a8fde75edbc188da7424a00b6
EBUILD nagiosplugin-1.3.2-r1.ebuild 519 BLAKE2B 2bb80a882e89a374199fbf066e226f9a53487f806f9c24736aac39bf39d16db808daf303a9f82f364f0eb1cecae1cb0ff00e3833e1f6fec165d989de60acd31a SHA512 2d7b5bb31d6089d66a119970aeccca99b21d4d6517d445360accf54423d6eb1394b5ac0fb261cb942e7857b05b755657a25c8c4ef4575016aa8a624dd23309fa
+EBUILD nagiosplugin-1.3.3.ebuild 551 BLAKE2B c5cc48272bb4a584f5814fb859fb68adebf49fda3105a1f1dc276f47fb250f9dc1d08f39042eda790553f095424f9d0c4290eea77a61e9dfa2d704adc204d36a SHA512 4c941083bb983618f07023f4eb5e2e95c6207afe0b2a2887b99bf92f0f50e811ae1b38929bd1b73e58cacffbd7350d7d850c86688731a3b393436e3f2adc9c01
MISC metadata.xml 453 BLAKE2B ff379e2cf739a4d002c710c1288e1476f2639a9f338f867f2ab680262beb7e11d98f1e78c304353b17d5bfcd2460e5a733921a452d9f8e3310644e6e1121ad97 SHA512 2a0fa4aba722284e5d83e318da82aa01b21ffde9dd59b3e44a858576ed26cac204b46f1f44e8acb74a8f5edf3de25c8a6fb5130b2a240ec4addf24d14f671cf2
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild
new file mode 100644
index 000000000000..34ac5df3aa48
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.3.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="ZPL"
+SLOT="0"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme