summaryrefslogtreecommitdiff
path: root/dev-python/nagiosplugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/nagiosplugin
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/nagiosplugin')
-rw-r--r--dev-python/nagiosplugin/Manifest2
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild19
-rw-r--r--dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild38
3 files changed, 20 insertions, 39 deletions
diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
index c2c053846eae..30cbea191893 100644
--- a/dev-python/nagiosplugin/Manifest
+++ b/dev-python/nagiosplugin/Manifest
@@ -1,3 +1,3 @@
DIST nagiosplugin-1.3.2.tar.gz 54262 BLAKE2B af2a8a876105a1ea26671b39d611beaa46303998544adadee3370c6d1b5096fa93160121f89412f3778a2bbc1c3e95606a49413b8f3f0880c9c9ca4e946fb1b8 SHA512 899650852397bffb66ad53843233adec2c91e96656674a9b21c5a02ed97ce4db69c1440d1b88c5799a54745e69b8c05f52188403b5a2fe9050acbd0067806d50
-EBUILD nagiosplugin-1.3.2.ebuild 870 BLAKE2B 733e2746c42aa9f91041b3e6bdaf5a72b96bd8c3da9da3b46eb3a96300ad5055eff3533739e5ef191e188145828e67094748a7ca64526ffcf0c2596603e543d0 SHA512 f6ec1e49b24dba7bd73890a14ae0acedc81009e972f2ce8c1156a0777efd3ded0a98f5651bc64d6dc53a33e6ac23b66b828da1314c14971acba72d6f177deaf6
+EBUILD nagiosplugin-1.3.2-r1.ebuild 519 BLAKE2B ccff76683f70387ca4ba47539d1d172ec026ec5e9675d558263e83b401a6e36960db9e2e74f0dd9ea7454da01440d9d31cf52d7db873ea60e1cdab71d9712c04 SHA512 05e1f500fec92f80dd822a8f123faae57b7e62c3111751ace4aebec3f6ba747795d37f1367270294fd6c1e7f94f0cc22f48483599a3d326dbefb681bcede962e
MISC metadata.xml 452 BLAKE2B 39030b9d85edf373418952f1986d9a1b4c5a73ca191112d9e979b754eb12891f16a522d19a4d4278853ec4b07aaaf14537ed64eed658886c02859d8a451eb81f SHA512 2eec420a3b59460798f9d8504d86a8d01afd309867f0bdb0f46f5a87484c06f8398221946bff4d06c150cf8085a6cbc15a9e61ba815519e696a26376cc018fe0
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..fba554d9f858
--- /dev/null
+++ b/dev-python/nagiosplugin/nagiosplugin-1.3.2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="ZPL"
+SLOT="0"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
deleted file mode 100644
index f342d816d30d..000000000000
--- a/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A class library for writing nagios-compatible plugins"
-HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-LICENSE="ZPL"
-SLOT="0"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build doc doc/_build/html || die
- HTML_DOCS=( doc/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv tests || die "tests failed with ${EPYTHON}"
-}