summaryrefslogtreecommitdiff
path: root/dev-python/myst-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 07:33:54 +0000
commit84d7c5e06639a9bcbf66ae744833b34422e478a6 (patch)
tree48da2d9483d2a87f954b8c4cf7c2024f2c773e45 /dev-python/myst-parser
parent92b7880bd28edc591d46c65b2242bbad6106fb39 (diff)
gentoo auto-resync : 03:03:2023 - 07:33:53
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest2
-rw-r--r--dev-python/myst-parser/myst-parser-0.19.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index d351d780a503..03e3a2256574 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,5 +1,7 @@
DIST MyST-Parser-0.18.1.gh.tar.gz 769288 BLAKE2B 77f21ae4277ef4ed9020caad86ef3ea92a1efca35f7ab61203fe2125e4fab31a74a740db7a1f1d6ea0a576c24706b0997beea296d782eb5a07ba4e91a0a9e52d SHA512 4bc3a89480f175779da4f093aaa99a1516f76ab4107dcf8747b6614f347e91739f8596693f95529d76aedbb0c84b4efde4262517bc445aa7027d51e05e8b48bc
DIST MyST-Parser-0.19.0.gh.tar.gz 812180 BLAKE2B 44dd773dfcbd8c01b3089303e81b103ce3eba2432b1891b4fb35b8bbd9c0088b3245e6afe14c6378a262cdd4e7930da16ddc7ab6abb3a06779d4d0bd9e9ebd53 SHA512 3b646b78032914b42ab655d5f653f38fb58e4c51814fca0f987c8207f6fb97db6f3ba6b9951b3ecdf98430800b2a198cc2b26f17162b5b57309bfe74de3f4450
+DIST MyST-Parser-0.19.1.gh.tar.gz 812247 BLAKE2B 24a3502d2b9f81ec066c8fc5055b59448938fda63e74b47810e16cb2ce57b17fab1e219469df6e57fd1343453012855f104806e05e0831166af3506adc8589f5 SHA512 abe57048a9c19cfa08bb11c2ab988ebe462b4a104ffe3fc3b9083e2563da0bda271b5b1e278ac94e1d328bb70f5aeb20e72f81fc428fbb79dd6fb695abfd01cb
EBUILD myst-parser-0.18.1-r1.ebuild 1701 BLAKE2B 77c03ca42b98dc71e32ba90aca09185b0436d0bc1ad9f4d780a0dc7594b5e88131866f08e40809a742025a51a86034af86c2969af168e98ceda4aca611f23231 SHA512 0ef1fd24fdb2e8361dcb783997dea12ae0aa8f4077028e1d2e768c705e4bdfdab4fad5f4e5cafe861d2a94d0cfb2197559e19250f97ad9ce6dc41298c7b06e35
EBUILD myst-parser-0.19.0.ebuild 1618 BLAKE2B 7ff69e8e0080be2d717fed3ce9a0f1b40dba9523ee0bcdbcc9b210b2252d362f76395398b92f5eef776ecd465d5557b586576b78a56f211e333819dd63850417 SHA512 a67d6346d87680a672e55f3a8544d28452435a1c25d35825c776b729265efe5dbbb0444cc51d717dbfa4a72927550c20f20d8ee2e468a13b2956d629a1a768af
+EBUILD myst-parser-0.19.1.ebuild 1618 BLAKE2B 7ff69e8e0080be2d717fed3ce9a0f1b40dba9523ee0bcdbcc9b210b2252d362f76395398b92f5eef776ecd465d5557b586576b78a56f211e333819dd63850417 SHA512 a67d6346d87680a672e55f3a8544d28452435a1c25d35825c776b729265efe5dbbb0444cc51d717dbfa4a72927550c20f20d8ee2e468a13b2956d629a1a768af
MISC metadata.xml 406 BLAKE2B d8a974be3dd4fef4800958dcb1eef3124dc8e3ec49e6678d0db7d6096ef290019aa025796c4f7c38bc11b750d1667ba97d4429b64e7271009da707cd945e113f SHA512 acdc27a39e068c487306002342b9c0c5910d61ed34a7b62878272054ea458d5aad46fe24095a52666ed77ffcb6e703687cc83de0c9e2cef395a1decf9003d918
diff --git a/dev-python/myst-parser/myst-parser-0.19.1.ebuild b/dev-python/myst-parser/myst-parser-0.19.1.ebuild
new file mode 100644
index 000000000000..c578ea90b4a1
--- /dev/null
+++ b/dev-python/myst-parser/myst-parser-0.19.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=MyST-Parser-${PV}
+DESCRIPTION="Extended commonmark compliant parser, with bridges to Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/MyST-Parser/
+ https://pypi.org/project/myst-parser/
+"
+SRC_URI="
+ https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/docutils-0.20[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+ >=dev-python/mdit-py-plugins-0.3.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ <dev-python/sphinx-7[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pytest-param-files[${PYTHON_USEDEP}]
+ dev-python/sphinx-pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_renderers/test_myst_config.py::test_cmdline
+ tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # bad test relying on exact exception messages
+ "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
+ )
+
+ epytest
+}