summaryrefslogtreecommitdiff
path: root/dev-python/myst-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 12:05:36 +0100
commit02eb6576978c38afed5787f6f2dbab8353379d66 (patch)
tree0b82220aae58c1307bef3aff0f342f4cdf858161 /dev-python/myst-parser
parent490ef2c2dc8b4e808f37add1adee21a754efd9a9 (diff)
gentoo auto-resync : 22:04:2024 - 12:05:36
Diffstat (limited to 'dev-python/myst-parser')
-rw-r--r--dev-python/myst-parser/Manifest3
-rw-r--r--dev-python/myst-parser/myst-parser-2.0.0-r1.ebuild (renamed from dev-python/myst-parser/myst-parser-2.0.0.ebuild)33
2 files changed, 29 insertions, 7 deletions
diff --git a/dev-python/myst-parser/Manifest b/dev-python/myst-parser/Manifest
index 390b80d45a02..db768a8401ed 100644
--- a/dev-python/myst-parser/Manifest
+++ b/dev-python/myst-parser/Manifest
@@ -1,3 +1,4 @@
DIST MyST-Parser-2.0.0.gh.tar.gz 815453 BLAKE2B 8f5dd823c3c79d843b45a7a4819d5677b51a12f78db2c1ce9700eb6faa8c4f0bc167fb1d8cd947e89ffab85aec947ab527b67dc73ef4db97a393f700a4331738 SHA512 c47bdd773565e93c4714d318a70f9a8adab1be6e2a63c23175667fc4afb5da4d66b84e11176782c8202e9fd68883e74d444911ddfb0b91356c2ba07fa65f7ea4
-EBUILD myst-parser-2.0.0.ebuild 1664 BLAKE2B 514c93f06f580695da2250affa13a01c5f9850c5c6f7ba6a0658ce6a36036800b929e8ea7544fc44c1df48b6f8cbeec5792fca29a4355b2c8791a0573d72d502 SHA512 a9081f7397c1cf586f6b85070f4d30173668c5ecd466a9fdb50af42c4cd855b11a761cd276b5bc1d21a7fc60b63f0e2ee88e799975996672b64d6ba1ec17aecd
+DIST myst-parser-2.0.0-sphinx-7.2.patch 22443 BLAKE2B 994f0b2c419832e61cb006b1b45c01274970900bdcfcef3422d5331e88962a46884afbf5b27b5cb98ed349a426444ca4ff21810526cc34eae4cf074102f7b3de SHA512 707b2a69c81352d2900c91088ca137f6455e0006b0e7c798b6f03b9f0cac85489c27db662f5e6ab6e2cd52e10f1594aa54d5c6821c07c110ad138d0cf129ac65
+EBUILD myst-parser-2.0.0-r1.ebuild 2408 BLAKE2B 3f4e599c57642d72e04b3549664945f15ed5674d2135f1b874e7b13c0db674e2d9ced463cba6b0c9f31be45d7e4826c88630ef07500ad92a62336531d4d1aa15 SHA512 813e57062b98269ad82a6252cfbd48ee368b50867445e05130e89eecf02df687c1b443a1b540f3f6e068971d85f7a2639bd19b0d9918c67eb8181d2677abbcd7
MISC metadata.xml 406 BLAKE2B d8a974be3dd4fef4800958dcb1eef3124dc8e3ec49e6678d0db7d6096ef290019aa025796c4f7c38bc11b750d1667ba97d4429b64e7271009da707cd945e113f SHA512 acdc27a39e068c487306002342b9c0c5910d61ed34a7b62878272054ea458d5aad46fe24095a52666ed77ffcb6e703687cc83de0c9e2cef395a1decf9003d918
diff --git a/dev-python/myst-parser/myst-parser-2.0.0.ebuild b/dev-python/myst-parser/myst-parser-2.0.0-r1.ebuild
index ce6cf989a97c..7d5eb87dbe12 100644
--- a/dev-python/myst-parser/myst-parser-2.0.0.ebuild
+++ b/dev-python/myst-parser/myst-parser-2.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,6 +17,8 @@ HOMEPAGE="
SRC_URI="
https://github.com/executablebooks/MyST-Parser/archive/v${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
+ https://github.com/executablebooks/MyST-Parser/pull/811.patch
+ -> ${P}-sphinx-7.2.patch
"
S=${WORKDIR}/${MY_P}
@@ -25,7 +27,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- <dev-python/docutils-0.21[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
<dev-python/markdown-it-py-4[${PYTHON_USEDEP}]
>=dev-python/markdown-it-py-3.0[${PYTHON_USEDEP}]
@@ -42,19 +44,38 @@ BDEPEND="
>=dev-python/linkify-it-py-2.0.0[${PYTHON_USEDEP}]
dev-python/pytest-regressions[${PYTHON_USEDEP}]
dev-python/pytest-param-files[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-7.2.6[${PYTHON_USEDEP}]
dev-python/sphinx-pytest[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
+src_prepare() {
+ local PATCHES=(
+ # https://github.com/executablebooks/MyST-Parser/pull/811
+ "${DISTDIR}/${P}-sphinx-7.2.patch"
+ )
+
+ default
+
+ # unpin docutils
+ sed -i -e '/docutils/s:,<[0-9.]*::' pyproject.toml || die
+}
+
python_test() {
local EPYTEST_DESELECT=()
- false && [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # bad test relying on exact exception messages
- "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
- )
+ if has_version ">=dev-python/sphinx-7.3"; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/executablebooks/MyST-Parser/issues/913
+ 'tests/test_renderers/test_fixtures_sphinx.py::test_syntax_elements[298-Sphinx Role containing backtick:]'
+ 'tests/test_renderers/test_fixtures_sphinx.py::test_sphinx_directives[341-versionadded (`sphinx.domains.changeset.VersionChange`):]'
+ tests/test_sphinx/test_sphinx_builds.py::test_references_singlehtml
+ tests/test_sphinx/test_sphinx_builds.py::test_heading_slug_func
+ tests/test_sphinx/test_sphinx_builds.py::test_gettext_html
+ )
+ fi
epytest
}