summaryrefslogtreecommitdiff
path: root/dev-python/mysql-connector-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/mysql-connector-python
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest2
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index c09152cbe98e..ed2c027635b0 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,5 +1,7 @@
DIST mysql-connector-python-8.0.22.tar.gz 12081967 BLAKE2B fc6b724ec2eb47a92294f7316093d4a4d2f4925981adeb07b305e946a047dbdaedd96c6ff9a07426fd56185f467cf6473bc84e0896d2e8fde70a188af16e9df2 SHA512 07f380922c18f9ade38f95d8e107fe8f90b8a7901fb9a36bbdfdb2b29f9cb79b0b6387a608e89bf90e9344c635d47184c750a206beacb2c9cc7615d6a7df2c29
DIST mysql-connector-python-8.0.23.tar.gz 12095843 BLAKE2B e4cc24f045d0e988ad97a9427fa3f6e20eb9d993d97f51033140e12722bc04fc3a2b252b811402daea2fea8f987948ebd8c68623f2af3e0e7e35d2b0d6fa7eda SHA512 66ca61c15573555a3f42ad8a9e9b3a4bc612c4d2b4e54928af87adcf609e131e9afd53b76c3a8da30f181e4f2111245cda5995063109526ff72f4f2062c2e528
+DIST mysql-connector-python-8.0.24.tar.gz 14600574 BLAKE2B 93efd9430ef65c63a3097d5af4b10e4875e306674d306161e10388c873f79213da3c04dcda9d32ad3f19021253014e1f98d884a3da70dbe8be1f6d96da2ec9ef SHA512 6b28a6017b8c4f78bf9710d9e0213bb6c0f63656b40a17e2576a82b6e249f0ae63c916d282392e577e8471d03ee19fa9e1f9a940e08f3dfec23a05064b851912
EBUILD mysql-connector-python-8.0.22.ebuild 1523 BLAKE2B 482d37af75f68fcfbf92074f82474a006e66376289a177e49e3421c25895d2a8cbdf40c4d9301a7b8fa17d69737252ef99a2196c969bc65b57cc000819ef86d5 SHA512 5f1eea17a35e9277f09eb8101c3e91d3b47ae9803b6c949afea3206b22757c73144081cb456faa1c46b992c7ca14a4b39997f35a12f79100f823d6dbd7eee970
EBUILD mysql-connector-python-8.0.23.ebuild 1524 BLAKE2B f97c6f95c11fa80fea43d8ac86d1f7369561f5bee7ae7e8826187e5d9b758d4ff85b6d3f1ffaf096d680fcfb4b8dcd7133e0203d89011dab60ed3b4789f68a42 SHA512 e2a3f26be785e0ec920b828584e7c9bee38ed78bdf336d2d2e02e595c0b5ad6441dd971b67a4e5219999b0ca5b05d31f9733bf200813b8b2cd86b733081a1f98
+EBUILD mysql-connector-python-8.0.24.ebuild 1555 BLAKE2B 7b2b7890a89ac612be17e73eba571feb5e4dc6d493a905c392dc0d16986a03f5d212cdf07e50ddea8968cc91ecf3a7c30fcabd08ce2bf133b718013b4e2ef81c SHA512 6b35f874775c6b5aecdff32ba64979ee9311fc4e46af3eb9bba79506040b2c579e59f29f0d17dd4b8f2ed82b63216fa63bd5aea4ad41d868dc12711aacd76cdd
MISC metadata.xml 429 BLAKE2B ecbfe7e88466287141bd923db191969d384118b464659804a4aad33d811a6042b8082c9675a103e3e50b1ccbf74357be609ed714890412d2534bc77388f6b61a SHA512 812597d8918eeb1c0b94b8afb0b605cf98fe6e0f3d4f79b644d90e78f026a13d1233c7c0665022c752818acf07deea7151b988a701c8a5060aefe9264c2a592f
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild
new file mode 100644
index 000000000000..454f690c682b
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://github.com/mysql/mysql-connector-python/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}