summaryrefslogtreecommitdiff
path: root/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild')
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
deleted file mode 100644
index cb3b42fdfd51..000000000000
--- a/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://github.com/mysql/mysql-connector-python/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="amd64 arm x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-BDEPEND=">=dev-libs/protobuf-3.6.1"
-
-RDEPEND="
- >=dev-db/mysql-connector-c-8.0
- >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
-"
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt README.rst )
-
-python_test() {
- "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
-}
-
-# Yeah, this is really broken, but the extension will only build this way during "install"
-python_install() {
- distutils-r1_python_install \
- --with-mysql-capi="${EPREFIX}/usr" \
- --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
- --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
- --with-protoc="${EPREFIX}/usr/bin/protoc"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples ; then
- dodoc -r examples
- fi
-}