summaryrefslogtreecommitdiff
path: root/dev-python/mypy_extensions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
commit519f4aac6d5896fe0204e6429485f95240c7ff58 (patch)
tree467adac90d818b96465a433b66ef6bb65e369fef /dev-python/mypy_extensions
parent8afe4133ba3d8586301516885427809020a3cafa (diff)
gentoo auto-resync : 05:02:2023 - 21:17:55
Diffstat (limited to 'dev-python/mypy_extensions')
-rw-r--r--dev-python/mypy_extensions/Manifest4
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild34
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild29
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/mypy_extensions/Manifest b/dev-python/mypy_extensions/Manifest
index cb9fbb2efe0a..9d75a97734d6 100644
--- a/dev-python/mypy_extensions/Manifest
+++ b/dev-python/mypy_extensions/Manifest
@@ -1,3 +1,7 @@
DIST mypy_extensions-0.4.3.gh.tar.gz 5545 BLAKE2B 8f1f988562390ee1ba3d90cafafec73c6fe080eef6b4321252d3b3aeffebf1ad13bdcae7ae75c69eac7bef91dcf3f846ae7f9a3f2ad6bad9de2bc8cfe5eed29f SHA512 22d8dc538cf6f77d97f4113dd34fce8095dd98944c7613fab2b3e71a3e9b7df1374654af41ead5c934f789ef1b72f54d980ab06f3ca28b8b4c6bb14ba1ca3ce2
+DIST mypy_extensions-0.4.4.gh.tar.gz 5555 BLAKE2B 89852229a2c37994aac1bdb0026a14489ea51b44286371d6b4711ad9b9df9a9827fd9b32bc7f2768b7e5890481560bd7221e1262f3e27b69fe964f9e0eb081e0 SHA512 86fe3cc95b856476e2f8df7f64084277411435a17726407fbd9a114e5684b8ffb0da1cf9eb3a17e19152e7958efcfaf57bf7236bcefe6eb7f4098b14ed302949
+DIST mypy_extensions-1.0.0.gh.tar.gz 6097 BLAKE2B 099616ee0bacad62d9ce642c3adb1eebe27546f7c567d1e0fa6ec04d9e6cbcda2966fff9769940cfda8b7d6cc9f33100af9d6f416ab2def26079668a16c354b3 SHA512 ac89a9f60a2c3df3457d5a6ab7ed47b72dd173646ef57f1450556051617e62046405a69fadeb40d2c24e68ce6ffed56d9182365e3203477facdc935e1a807847
EBUILD mypy_extensions-0.4.3-r2.ebuild 790 BLAKE2B 2faf75075712f075aff24803d8a49fd7fc357e3f6de384ebc00e36133d6c98df133d3da08f8c8a4a0d742e279e20e677df5dc2c650068dc0c5ed021a50c03175 SHA512 d6fcb1d70eba7bee40e3cb4dadc2643e209cc8ca5e6946e82c65a4a0a59fba76f1f51c011c67bcb626e7c6369e2dba6a11ecba5ec5b61167a76a0fbc05a3a01b
+EBUILD mypy_extensions-0.4.4.ebuild 805 BLAKE2B 3f2ab1c61051fff660c715f021daf38e1a89dc10b6f1ed4f32bdddd72539dc08cb9c63435bcb521895dc63dc614df5ebdf5775d1cc163c0cac05ce587b45933e SHA512 55657958647a766b0e1b0851c79087c2576f12e43bd76add2c8b8e7970f8dd02056277a9e82959cf4e23e3ebf1216308ed4c9d3b5b4d5c49e6a3e6fb34fa5e09
+EBUILD mypy_extensions-1.0.0.ebuild 661 BLAKE2B 49591255edb6dc180dd9221efdd746af93740edb4ddfd4a26ae9e2542352a9ef1a110cf61282e1e09c9b714784214e1436bb5bc7732eeae12ec1c0fcffd3df60 SHA512 75ef86965b3e49fcc22aa2db512d602ae17dde150b68acb46911466afdcf5c1d74e814ce9453d2c2021cb254cdb113f16d2f08d4ff45070a15d730e67a183902
MISC metadata.xml 405 BLAKE2B eaf484f8baf4a4353f55fc7a84a40057c70adc6a5403e5f2e22f84d804f63774b60c52ddcdb4cc59fa21f3c350ea772f7eeb12112610d611c053ef82340a1e92 SHA512 26bd5e50dd2d591c6bcc803d27e85fa0508921c688d798e208868b7c9a77bee999ef12732038af42dc62fdbec75b7cfbbd6ff33256756736bcc783893aeaf586
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild
new file mode 100644
index 000000000000..3fa95ff86e2a
--- /dev/null
+++ b/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy_extensions/
+"
+SRC_URI="
+ https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This test assumes we get a TypeError, but that is no longer true in 3.11
+ "tests/testextensions.py::TypedDictTests::test_typeddict_errors"
+)
+
+python_test() {
+ epytest tests/*.py
+}
diff --git a/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild b/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
new file mode 100644
index 000000000000..7dfecc74deb8
--- /dev/null
+++ b/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Type system extensions for programs checked with mypy"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy_extensions/
+"
+SRC_URI="
+ https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/*.py
+}