summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-21 07:18:34 +0100
commite4cd098fab4f141df4d2fd24dfdc9b5f223c694b (patch)
treec8abdb0925677514b0f735dbb8f19255088ae694 /dev-python/mypy
parent7d4e34d0bcf06b357fd09a059a02687acf335132 (diff)
gentoo auto-resync : 21:06:2023 - 07:18:34
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.4.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 894ff69a63e2..3af646406130 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,5 @@
DIST mypy-1.3.0.gh.tar.gz 2823529 BLAKE2B 0f1b4b6178ef9308fa6aeda494092229ebe07095c032b83fffd28be851608a3dc92ae4924ea64d87318155bf9d99bf16e17e2603f39fc915463455db520d6138 SHA512 1ab0e667bd019ea6804c70c775c2bfb454231ca2426b2b78b5c91672f7f20fd1195ee481a688d9b6238c3b5f6dc9a7aa5466c7405ce71dd6f78c489a43670fc0
+DIST mypy-1.4.0.gh.tar.gz 2863445 BLAKE2B e6d700a464d6ddb2ef49fd0dadca2139e7b21ebb33753e5f4ec0a60f7cac623d853dcf02cb096397c52e35c39182a082ade11b57e2a7a116bdeb9a606f854a99 SHA512 69aa3babe77c6f7576d01f29e4b9cf456bfcf7689a82d5156967c04f85ff823b34907ae006db75f1accfa52a76b51d98de1a9d307c32e70a4130046c13087501
EBUILD mypy-1.3.0.ebuild 1864 BLAKE2B c3a3541b8267cf0c43860f5ebc4dabfb7f83df15af99253a012b95ca3efd550706930806840a51098e6e4560d401081380025525c1fd80b08eb73ade35daa62e SHA512 09aa65b2e52605c34122c5e64f96bd044a43167ed86233aca6c16daa3e211f4b910a7daf8d3586598ee5261b79bfcc904f9db46d4e3da9cc7776bad80bdae10e
+EBUILD mypy-1.4.0.ebuild 1873 BLAKE2B 2e3a8da162c2e730aa2b3717c6849b0f5d0fcb2bac79038e8c81e439beab42efbe9587eeec73148a574bd69fd2a75cde9f6f93de46cb0291aaa32a483adb6ce8 SHA512 ee4e81c62488fd2aed0617cbc3a79710d4b66c053c137372be3b69046e6e2ad3d6a26b81a0b03cb252cdad01d88153a0950128212b939d6882c962e3d02a0ba5
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-1.4.0.ebuild b/dev-python/mypy/mypy-1.4.0.ebuild
new file mode 100644
index 000000000000..7f68a1adc813
--- /dev/null
+++ b/dev-python/mypy/mypy-1.4.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' pypy3 python3_{8..10})
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/furo
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ )
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}