summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-19 09:49:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-19 09:49:52 +0100
commitd99752d3d5e12a0fc38778cb734bc68bbe2ed3bb (patch)
tree5f37e3f56df65ede7caf11eb0bd1fbf0ee03ac3c /dev-python/mypy
parenta643f0010255d34e6b8045aba39aef5174921a7d (diff)
gentoo auto-resync : 19:10:2023 - 09:49:52
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.6.1.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 2d27a313024f..2c9f84156531 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,5 +1,7 @@
DIST mypy-1.5.1.gh.tar.gz 2901212 BLAKE2B b136cf061162bc50a48f1556763d7a1258b5a29b63a77db9190f89c56d3e85375a2b0e826d75472a0dc37df4d3391f2d85bb5f1f29c2907055a978e3c8d75906 SHA512 2c81322c0e7d9621e6d189f4d9d25d77c5fd6decbb563c8d0015e0f94ff1ff8206e5b7a38884edd3eedb99e839c03283ebfa7d86577c9f8e0d707c0cc4eb8fed
DIST mypy-1.6.0.gh.tar.gz 2923757 BLAKE2B 15e0fe124b7024a3e89a8c32c13404f33bc56a3ff29375d006bfcaf9de359ea59025ba07e3726c7a4b402f4b7aca1256859585e1500891fb1e5f996b19dd499a SHA512 245324a5ec8a98e18c31159c5cb907ce1b60323428942b9fd60909a3b117ae46eeb97792fb1f30562fa411edb6c9e903f87b5b232a4be1242abe28d88406f7c4
+DIST mypy-1.6.1.gh.tar.gz 2923973 BLAKE2B 1abaaab0c4ca4daa4914d69196312e371d030b6f81616da66102c5fcf6ad55ed2a6a9d56f9a55d2b6ebeb055b40947ab042e7b8744960185f5343dd9f05f9f4f SHA512 eac6b17dd418146c365a446e34c2cb403692a6ffa08b06a94c54accfbcedd441284c95894ef9f9b83e48df81edc35893b17163f6dba9f81fe7e9a8527401968b
EBUILD mypy-1.5.1.ebuild 1548 BLAKE2B a8aedcd6bbb5efe0cdebd4451ea3b0ef2eba9d66c89802d73fea4785c97fb75f748267431686325e22217321b5d8d3f3789b83a0b349b4b159ed0bd87e5c3f9c SHA512 a1d829e224dc3b12d0ae50fa8774c5414cbd5c13106a8d29004a525295ef11cbede074052b4fd71af2cbcb69c9bf330c7d8cba487b8ec00e9d1de8d3915557b4
EBUILD mypy-1.6.0.ebuild 3179 BLAKE2B a2d52fa5fb90cd9a0b8f44b13ff0c42245e67e8fa7ee63c16c4368da0bcb69c83588273805560fe98cd1e447b043dce06251760bab419973e92375e664c2cbce SHA512 3ef1c896dad846a1a96269535054d782a1ddac7b3b326783860a184f25f61878770786847f4cf54ce7c9e62ffa61cca138a6b17634e0022903418d1516d767ec
+EBUILD mypy-1.6.1.ebuild 3563 BLAKE2B 0a584c5be3cf613735cff1ff28eb5202fe3b905016531b0f425ac423096c5ad1b64b0563aa95fcca3b7563bb537b72de32ff124df96e78d8b87b93d6406ab011 SHA512 8b5f9e64bfa13f4441384eb10d7bd107e42b0ace30c52b3706f4b5ca74c1bc46e5143bb3ee4021205f3dd13e2379d1a64bc6655debf17e9c7645ac8ca8e850ab
MISC metadata.xml 661 BLAKE2B df57cc2dfde5b112f8c26b51ca5cc9e7727d318ee274ea7e1abf448819daf0307f471aeb7c32b19f20e87ce1ccffd47a5529415003765c275523e1b5236f3bb1 SHA512 eddd19c4b0b5211f73f9619f388a799ced108b62bb43d852ed2d01d0b1717e7b9ef118d34b9d61db543c7b47080fb8058c3d35f7359cc456069636f357e080c9
diff --git a/dev-python/mypy/mypy-1.6.1.ebuild b/dev-python/mypy/mypy-1.6.1.ebuild
new file mode 100644
index 000000000000..c459aac6a8e5
--- /dev/null
+++ b/dev-python/mypy/mypy-1.6.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/types-psutil[${PYTHON_USEDEP}]
+ dev-python/types-setuptools[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# frustratingly, mypyc produces non-deterministic output. If ccache is enabled it will be a waste of time,
+# but simultaneously it might trash your system and fill up the cache with a giant wave of non-reproducible
+# test files (https://github.com/mypyc/mypyc/issues/1014)
+export CCACHE_DISABLE=1
+
+src_compile() {
+ local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ # known broken with assertions enabled
+ # https://github.com/python/mypy/issues/16043
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64GlueMethodsAndInheritance
+ mypyc/test/test_run.py::TestRun::run-floats.test::testFloatOps
+ )
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # more assertions, sigh
+ mypyc/test/test_run.py::TestRun::run-bools.test::testBoolOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64BasicOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64DefaultArgValues
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64ErrorValuesAndUndefined
+ )
+ fi
+
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+
+ # The tests depend on having in-source compiled extensions if you want to
+ # test those compiled extensions. Various crucial test dependencies aren't
+ # installed. Even pyproject.toml is needed because that's where pytest args
+ # are in. Hack them into the build directory and delete them afterwards.
+ # See: https://github.com/python/mypy/issues/16143
+ local -x MYPY_TEST_PREFIX="${S}"
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ cp -r "${S}"/{conftest.py,pyproject.toml} . || die
+
+ local failed=
+ nonfatal epytest -n "$(makeopts_jobs)" --dist=worksteal || failed=1
+
+ rm conftest.py pyproject.toml || die
+ # leftover test files
+ rm -r mypyc/lib-rt/build || die
+ rm mypyc/lib-rt/test_capi*.so || die
+ rm mypyc/external/googletest/make/*.[ao] || die
+
+ [[ ${failed} ]] && die "epytest failed with ${EPYTHON}"
+}