summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
commita17b25a10359070f9527893d861369d378021aa9 (patch)
tree02188942c1da9eb507b509fbd36c9b7a5aff86c8 /dev-python/mypy
parentefbb52742172c497c5245486906aade0fb6220e8 (diff)
gentoo auto-resync : 07:04:2023 - 11:29:55
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.2.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 33660958fc00..7ccf74a1ed96 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,5 +1,7 @@
DIST mypy-1.0.1.gh.tar.gz 2763553 BLAKE2B d8d2b6cd3ff386ce0f78d32f81f3f631bbb8ffdbebab8607af2496c890b6a876f870e487a88711b93e48615548aaf6fa32cc6f62cf472d2def59374b49818584 SHA512 081b1ada479ea694e570f6ac56e470196efe30cc5bd8d8e32255ca980a312d67779746eb3f780ecb4d83e8d7e3272fcc77231ba098e736be5893cf249b7ff84e
DIST mypy-1.1.1.gh.tar.gz 2787425 BLAKE2B e72a4dcb41107e6438b360bb342b7ac42778ab3d6bd557d7fe2a9f92f6427d94d782661ff80bee36aafa676d0cc1553bcfd74cf3e413d4afa525fd8e93e9b87e SHA512 fcd50366837d005f255e2e8ecf20c843374a5d7670d714d1f8cfdaef1c6d44e37e7e84ba91fd1d49513e3aeffc8d5c0ab40ddd7bc9fced75082c9fea60d38f6a
+DIST mypy-1.2.0.gh.tar.gz 2815323 BLAKE2B d5cdc1bb31d797c49daf5ea0427fdceaf59a131d02a687dc5e72796a03824bff923c6942c6f01ca44025fe153fea02fdaee3959317fda0d4c562c45638e8c380 SHA512 5bee7a5ae4ac608cb3b3855c0ad100ea6ba512900aa557a153e1ae5f8e779125a8ef61103a81a9584b0585a6d4eea78c3585af61fa62986f984ac2b63e6b89b6
EBUILD mypy-1.0.1.ebuild 1773 BLAKE2B 978c99ff419963ed8079eb2289fa1888ccf559ee86f4c6c2781915928825dca9c5f822294593a4912199d758e36f9eba9caa2ae0b35f7ffd8e199010e9c477ae SHA512 ac9cc6f424fc399ee4eb8328e917c9e3866c6ec4fdc4ab72c7e970713b54bfd7090a387b73bc2f799e3b2eff743e79a2179c2c02a623aacd2b5e81504bd0ba33
EBUILD mypy-1.1.1.ebuild 1730 BLAKE2B d551dcf3e6533016345a05ab95a050df3fd2bef314cfa0f804637507b38c97d82097ae497d86eb298e7433ad522502197a7ba66355cea1f2515d408abe1f5be9 SHA512 910864eccebd73e17b097fff17a11b04b63e84b361332a053aecee2d7d86618573f4492bf192c7034eb8ecbf45223fee6d986a04619e3c7e234ad09d171d04fa
+EBUILD mypy-1.2.0.ebuild 1730 BLAKE2B d551dcf3e6533016345a05ab95a050df3fd2bef314cfa0f804637507b38c97d82097ae497d86eb298e7433ad522502197a7ba66355cea1f2515d408abe1f5be9 SHA512 910864eccebd73e17b097fff17a11b04b63e84b361332a053aecee2d7d86618573f4492bf192c7034eb8ecbf45223fee6d986a04619e3c7e234ad09d171d04fa
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-1.2.0.ebuild b/dev-python/mypy/mypy-1.2.0.ebuild
new file mode 100644
index 000000000000..602afdd767cd
--- /dev/null
+++ b/dev-python/mypy/mypy-1.2.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' pypy3 python3_{8..10})
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/furo
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}