summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 12:52:47 +0000
commit8b256c06858dd62dc5a70f801c732e9ab8226123 (patch)
treed30e45ce0630a0f829dc01cd744061ba3f500811 /dev-python/mypy
parent9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (diff)
gentoo auto-resync : 15:11:2022 - 12:52:47
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-0.991.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index add34a3b6af6..81605661cdf1 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,5 @@
DIST mypy-0.990.gh.tar.gz 2693855 BLAKE2B d4c4408c763e9e540c1680704b427d0bc41068d926742ab7b33d5f27a33156322d56aba0e56e5b1be44d197a1b44c6c5e552c44f44b77a590e01168361d5b97c SHA512 a503c9a18e808d49d404eeae5d8d7c20193bca1f07c198cc880538960904e72226545f1b72fef083599af40124dfb35326b70e69c1e5cf3fea8db3b46c930fee
+DIST mypy-0.991.gh.tar.gz 2694440 BLAKE2B 857c991a17f5a0195d5c7db60e73427695b64d3c3181b26919ed40a2b825ef5e8f30890a4ca7a55b739087af47f025b1d324563f5ef5e2f58c363562ecc49365 SHA512 02663494700d4ab6d08ab2199a7a81ad144ed090774326ea8d418dec37faec6d3b078f1c3120b8b014a676d69d5dc4e9b528b759c2de086a18569016b28b00d5
EBUILD mypy-0.990.ebuild 1763 BLAKE2B c8832146bf0867424c4366b23d373ec45c9866afd5080b407306cb9cef3565a93a279a9464f5f8587c2d16cd7c6029a44041db308f0cc485a37e47d8a538d36d SHA512 aec2779613635c50067ac0ab6e7375bab23df8d902b586ea0850a7b573e3647f161f70ee19d090dbc833a1dc5be13da0adc01981dbf3fea97f6797df3e404179
+EBUILD mypy-0.991.ebuild 1771 BLAKE2B 2c8c1384773ee385e6bd94ffa6057c76f5c893bcd30efceb6882c4eedadd237c28fe0a142a916d2bad0b6f5f7e8fc67b239095d5887e20d232f8f0071f7f99ef SHA512 d7711db7d8db2f8c77b035606ed29e80a926504d4af314c8996ffb494e073a56f6cc91bf7e56e0f98b1cc91864f3aee6eacb6ca00e64d5428e3b6189bb313572
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-0.991.ebuild b/dev-python/mypy/mypy-0.991.ebuild
new file mode 100644
index 000000000000..4c893f33c12d
--- /dev/null
+++ b/dev-python/mypy/mypy-0.991.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ http://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/furo
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}