summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-16 04:04:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-16 04:04:29 +0100
commit61a1cada8ceb208845fa604b982216b0a7b099cb (patch)
treed91d334e3ed29648631d4c04be64001120d48e44 /dev-python/mypy
parent45392c898b8ba163e95028bd98896e77f0c73806 (diff)
gentoo auto-resync : 16:10:2024 - 04:04:29
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.12.0.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 628d03416ece..4618ba0fa355 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,5 @@
DIST mypy-1.11.2.gh.tar.gz 3122502 BLAKE2B 228127662f4c607aacf3ee37410d0fa039a225fdbf2fec27eefab4aaabf4b68fa33499bb978aa5f06e24b45b525ce524decfa84f4d7d6bb7961724db92a4589b SHA512 c25584db08adcf7693944e5a6a41743101e80a0ff03f36f0353a07674ad4e2d63dbd4ff3fa0e307c19d63bc5aac9f7523340bd5a7cb3661642f3fb33759aafd0
+DIST mypy-1.12.0.gh.tar.gz 3163109 BLAKE2B d532d60117f29da66e8c29d3532b3c325cf0cbce04ba075fa949bb734a36e1929d67ce804618dce09fac4dba990970900560365755d95e3a388755da5bdd8cff SHA512 7720b9625dcb30482993162468366596dad2245ee5113c2f3cd7a8175941d339eadbba05a9dd8c8cba3fbed1e3c6ecbcd8c58965c5b585bad1870e401279e656
EBUILD mypy-1.11.2.ebuild 3905 BLAKE2B 1150897e24c51af84c5f7af491ce109393090b835f78936aba7c98c77d513b550520c6a4e3fdde6161d34fa504c76e797792c07c8d41637bbf9e270ea337e13f SHA512 18b4170b35653647092c8bee866d201fe53743b2681651d422316258ec36ded52353001beabc464809d4a5716a1fbba6d91d9c8164733a4b57f325f55db7fe29
+EBUILD mypy-1.12.0.ebuild 3654 BLAKE2B a5ee7bff7e6b8244447b0c34c7491a1367a021454bb743b0c2daece1176e93ab7a45005610576207bc8ff08600ebc6a4bcd1655d10c19ce0c46cd7ce076a47e1 SHA512 47c081d44395a5a9c2e41090c4b7582ebd06fb472d97baca1fa58199508d07cb874658ca45012734f595cd7b3b28fd5bf8ca039f157046eb47389c4c9366aebc
MISC metadata.xml 661 BLAKE2B df57cc2dfde5b112f8c26b51ca5cc9e7727d318ee274ea7e1abf448819daf0307f471aeb7c32b19f20e87ce1ccffd47a5529415003765c275523e1b5236f3bb1 SHA512 eddd19c4b0b5211f73f9619f388a799ced108b62bb43d852ed2d01d0b1717e7b9ef118d34b9d61db543c7b47080fb8058c3d35f7359cc456069636f357e080c9
diff --git a/dev-python/mypy/mypy-1.12.0.ebuild b/dev-python/mypy/mypy-1.12.0.ebuild
new file mode 100644
index 000000000000..0f181ed2e8ed
--- /dev/null
+++ b/dev-python/mypy/mypy-1.12.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+native-extensions"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ native-extensions? (
+ ${RDEPEND}
+ dev-python/types-psutil[${PYTHON_USEDEP}]
+ dev-python/types-setuptools[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+# frustratingly, mypyc produces non-deterministic output. If ccache is enabled it will be a waste of time,
+# but simultaneously it might trash your system and fill up the cache with a giant wave of non-reproducible
+# test files (https://github.com/mypyc/mypyc/issues/1014)
+export CCACHE_DISABLE=1
+
+python_compile() {
+ local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
+ case ${EPYTHON} in
+ python3.13)
+ # https://github.com/mypyc/mypyc/issues/1056
+ MYPY_USE_MYPYC=0
+ ;;
+ esac
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ # known broken with assertions enabled
+ # https://github.com/python/mypy/issues/16043
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64GlueMethodsAndInheritance
+ mypyc/test/test_run.py::TestRun::run-floats.test::testFloatOps
+ # these assume that types-docutils are not installed
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testIgnoreImportIfNoPython3StubAvailable
+ mypy/test/testpythoneval.py::PythonEvaluationSuite::pythoneval.test::testNoPython3StubAvailable
+ # TODO
+ mypy/test/meta/test_parse_data.py
+ mypy/test/meta/test_update_data.py
+ )
+ case ${EPYTHON} in
+ python3.13)
+ ;&
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # more assertions, sigh
+ mypyc/test/test_run.py::TestRun::run-bools.test::testBoolOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64BasicOps
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64DefaultArgValues
+ mypyc/test/test_run.py::TestRun::run-i64.test::testI64ErrorValuesAndUndefined
+ )
+ ;;
+ esac
+
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+
+ # The tests depend on having in-source compiled extensions if you want to
+ # test those compiled extensions. Various crucial test dependencies aren't
+ # installed. Even pyproject.toml is needed because that's where pytest args
+ # are in. Hack them into the build directory and delete them afterwards.
+ # See: https://github.com/python/mypy/issues/16143
+ local -x MYPY_TEST_PREFIX="${S}"
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ cp -r "${S}"/{conftest.py,pyproject.toml} . || die
+
+ local failed=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest || failed=1
+
+ rm conftest.py pyproject.toml || die
+
+ [[ ${failed} ]] && die "epytest failed with ${EPYTHON}"
+}