summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /dev-python/mypy
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.3.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index fe60b62c6b74..39a5c8442279 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,5 @@
DIST mypy-1.2.0.gh.tar.gz 2815323 BLAKE2B d5cdc1bb31d797c49daf5ea0427fdceaf59a131d02a687dc5e72796a03824bff923c6942c6f01ca44025fe153fea02fdaee3959317fda0d4c562c45638e8c380 SHA512 5bee7a5ae4ac608cb3b3855c0ad100ea6ba512900aa557a153e1ae5f8e779125a8ef61103a81a9584b0585a6d4eea78c3585af61fa62986f984ac2b63e6b89b6
+DIST mypy-1.3.0.gh.tar.gz 2823529 BLAKE2B 0f1b4b6178ef9308fa6aeda494092229ebe07095c032b83fffd28be851608a3dc92ae4924ea64d87318155bf9d99bf16e17e2603f39fc915463455db520d6138 SHA512 1ab0e667bd019ea6804c70c775c2bfb454231ca2426b2b78b5c91672f7f20fd1195ee481a688d9b6238c3b5f6dc9a7aa5466c7405ce71dd6f78c489a43670fc0
EBUILD mypy-1.2.0.ebuild 1722 BLAKE2B ff97e66a7db6be860b52578a5f0ea47431df0764b0ab019a5d1946e90ebead5f4c4ce4f1ca7e94f6dd262a1b8d4453319011bb8e9bca5387a0546c1eb728a0db SHA512 ffe15c00e32805d8363c95e5eb58550e0f2a2e48ab39b345a2456fb06f47fb395fe9bc84c0a774dea2e12ba2562309b3677b5688de2af80dc9be9db317b28b44
+EBUILD mypy-1.3.0.ebuild 1837 BLAKE2B 62b3882be65da1b260248d89f4263574476ea96b6a7f3b6b5aad085da53134846a5f25be0025fd23ccceed512c3eac4cd6b82b7f5f076734725659afba5b7852 SHA512 a8251667b7a645ebc7dde210eba540e73989df88f67f94a44626ebc3a5b98732bcf56709cb7a6d4c570fa20a312c2dce509dd0fdd070d8e583a457642862e489
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-1.3.0.ebuild b/dev-python/mypy/mypy-1.3.0.ebuild
new file mode 100644
index 000000000000..3ff1a529547c
--- /dev/null
+++ b/dev-python/mypy/mypy-1.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' pypy3 python3_{8..10})
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/furo
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ )
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}