summaryrefslogtreecommitdiff
path: root/dev-python/munkres/munkres-1.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
commitd473a706836012853193afc7000922601e4ada61 (patch)
tree01c43bd6b2121d90bc97ead47dd7654d9402ea1d /dev-python/munkres/munkres-1.0.12.ebuild
parent420eeee727d39d869d864caddb04a80dafda7160 (diff)
gentoo resync : 19.10.2017
Diffstat (limited to 'dev-python/munkres/munkres-1.0.12.ebuild')
-rw-r--r--dev-python/munkres/munkres-1.0.12.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/munkres/munkres-1.0.12.ebuild b/dev-python/munkres/munkres-1.0.12.ebuild
new file mode 100644
index 000000000000..aa2827883266
--- /dev/null
+++ b/dev-python/munkres/munkres-1.0.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="https://pypi.python.org/pypi/munkres/"
+SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ "${PYTHON}" ${PN}.py || die
+}