summaryrefslogtreecommitdiff
path: root/dev-python/munch/munch-2.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/munch/munch-2.5.0-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/munch/munch-2.5.0-r1.ebuild')
-rw-r--r--dev-python/munch/munch-2.5.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/munch/munch-2.5.0-r1.ebuild b/dev-python/munch/munch-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..ddd6c95ef23a
--- /dev/null
+++ b/dev-python/munch/munch-2.5.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A dot-accessible dictionary (a la JavaScript objects)"
+HOMEPAGE="https://github.com/Infinidat/munch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~x86"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/munch-2.5.0-revert-pbr.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s:__version__:'${PV}':" setup.py || die
+}